Bug 40545 - focusin, focusout, activate not implemented in SVG
: focusin, focusout, activate not implemented in SVG
Status: RESOLVED WORKSFORME
: WebKit
SVG
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To:
:
: HasReduction
:
:
  Show dependency treegraph
 
Reported: 2010-06-13 09:25 PST by
Modified: 2011-06-28 09:11 PST (History)


Attachments
focusout demo (1.39 KB, image/svg+xml)
2010-06-13 09:37 PST, jay
no flags Details
focusout simplified testcase (791 bytes, image/svg+xml)
2010-06-14 01:02 PST, jay
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-06-13 09:25:33 PST
http://www.w3.org/TR/SVG/interact.html#SVGEvents

focusout: Occurs when an element loses focus, such as when a 'text' becomes unselected.

it is not clear to me how this is intended to be used, however please find a testcase attached

in Safari and Opera, clicking on a green rectangle starts its own flashing cursor

however only in Opera does one animation stop when the other starts.

please accept my apologies for the code, an even simpler testcase would be appreciated.
I had the devil's own trouble getting this one to function at all.
------- Comment #1 From 2010-06-13 09:37:58 PST -------
Created an attachment (id=58595) [details]
focusout demo
------- Comment #2 From 2010-06-14 01:02:30 PST -------
Created an attachment (id=58625) [details]
focusout simplified testcase
------- Comment #3 From 2010-06-14 01:03:22 PST -------
very much simplified testcase, wfm Opera, broken Safari
------- Comment #4 From 2010-06-14 01:16:16 PST -------
http://www.w3.org/Graphics/SVG/Test/20061213/svggen/script-handle-02-b.svg
is the definitive test
------- Comment #5 From 2010-06-14 01:31:21 PST -------
url above is for script access using onfocusout etc.
------- Comment #6 From 2010-06-14 12:13:03 PST -------
in August 2000 Accessibility Features of SVG  states:
"Good authoring practice will normally use the focusin, focusout and activate events rather than the device specific events for gaining and losing the focus on an element or activating the element. "
http://www.w3.org/TR/SVG-access/

Opera implementation allows either focus or focusin
------- Comment #7 From 2010-06-17 22:30:32 PST -------
moving to DOM as whilst the effect is SVG the cause is DOM
------- Comment #8 From 2010-07-09 07:27:02 PST -------
Changed component to SVG, so it shows up in my all-svg-bugs search.