Bug 40532 - webkitgtk-1.2.1: testwebresource.c failed
Summary: webkitgtk-1.2.1: testwebresource.c failed
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-12 14:39 PDT by Pacho Ramos
Modified: 2010-07-09 01:10 PDT (History)
2 users (show)

See Also:


Attachments
build.log.bz2 (104.39 KB, application/octet-stream)
2010-06-12 14:39 PDT, Pacho Ramos
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos 2010-06-12 14:39:57 PDT
Created attachment 58565 [details]
build.log.bz2

When running tests, we are getting this problem downstream:
http://bugs.gentoo.org/show_bug.cgi?id=323669


TEST: Programs/unittests/testhittestresult... (pid=940)
Xlib:  extension "RANDR" missing on display ":1.0".
  /webkit/hittestresult/document:                                      OK
  /webkit/hittestresult/image:                                         OK
  /webkit/hittestresult/editable:                                      OK
  /webkit/hittestresult/link:                                          OK
PASS: Programs/unittests/testhittestresult
TEST: Programs/unittests/testwebsettings... (pid=957)
Xlib:  extension "RANDR" missing on display ":1.0".
  /webkit/websettings/user_agent:                                      OK
PASS: Programs/unittests/testwebsettings
TEST: Programs/unittests/testwebresource... (pid=960)
Xlib:  extension "RANDR" missing on display ":1.0".
  /webkit/webresource/get_url:                                         OK
  /webkit/webresource/get_mime_type:                                   OK
  /webkit/webresource/get_text_encoding_name:                          OK
  /webkit/webresource/get_frame_name:                                  OK
  /webkit/webresource/get_data:                                        OK
  /webkit/webresource/loading:                                         OK
  /webkit/webresource/sub_resource_loading:                            **
ERROR:WebKit/gtk/tests/testwebresource.c:279:test_web_resource_sub_resource_loading: assertion failed: (sub_resources->next)
FAIL
GTester: last random seed: R02Saeafdd62d81a35820b11fed661cce0ed
make[2]: *** [test] Terminado
make[2]: Leaving directory `/var/tmp/portage/net-libs/webkit-gtk-1.2.1/work/webkit-1.2.1'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/webkit-gtk-1.2.1/work/webkit-1.2.1'
make: *** [check] Error 2

I attach full log with all the output
Comment 1 Pacho Ramos 2010-07-08 09:57:03 PDT
We are running libsoup-2.30.2
Comment 2 Gustavo Noronha (kov) 2010-07-08 10:32:08 PDT
I'm unable to reproduce this problem locally with any of my webkit builds. It might be worth noting that most of the developers and the buildbots run debian, and ubuntu.
Comment 3 Pacho Ramos 2010-07-08 14:09:48 PDT
Yes, it works ok when building manually from sources :-/

Sorry for the inconvenience

(Also note that tests still need X for running, or they will fail with:

make  check-am
make[1]: Entering directory `/home/pacho/Desktop/webkit-1.2.1'
/bin/mkdir -p ./.deps/DerivedSources
make  check-local
make[2]: Entering directory `/home/pacho/Desktop/webkit-1.2.1'
gtester --verbose Programs/unittests/testhttpbackend Programs/unittests/testloading Programs/unittests/testglobals Programs/unittests/testmimehandling Programs/unittests/testnetworkrequest Programs/unittests/testnetworkresponse Programs/unittests/testwebframe Programs/unittests/testwebbackforwardlist Programs/unittests/testwebhistoryitem Programs/unittests/testwindow Programs/unittests/testdownload Programs/unittests/testatk Programs/unittests/testhittestresult Programs/unittests/testwebsettings Programs/unittests/testwebresource Programs/unittests/testwebdatasource Programs/unittests/testwebview Programs/unittests/testkeyevents;
TEST: Programs/unittests/testhttpbackend... (pid=4050)

Gtk-WARNING **: cannot open display: 
aborting...
FAIL: Programs/unittests/testhttpbackend
make[2]: *** [test] Terminado
make[2]: Leaving directory `/home/pacho/Desktop/webkit-1.2.1'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/home/pacho/Desktop/webkit-1.2.1'
make: *** [check] Error 2
)
Comment 4 Pacho Ramos 2010-07-09 01:10:03 PDT
The original problem was caused by affected test trying to create /root/.recently-used.xbel and not being able to since portage compiles and run tests into a sandbox. We now have workarounded it downstream setting a different XDG_DATA_HOME