Bug 40360 - Windows build break due to C4819 warning
Summary: Windows build break due to C4819 warning
Status: RESOLVED DUPLICATE of bug 40358
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-09 05:31 PDT by Kwang Yul Seo
Modified: 2010-06-09 08:59 PDT (History)
1 user (show)

See Also:


Attachments
Patch (2.48 KB, patch)
2010-06-09 05:34 PDT, Kwang Yul Seo
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kwang Yul Seo 2010-06-09 05:31:50 PDT
WKCAImageQueue.cpp and MediaPlayerPrivateFullscreenWindow.cpp contain non-ASCII double quotation marks around "AS IS".  This causes C4819 warning in Korean version of Windows. I think it may cause the warning in some of non-English  Windows too. Replace the double quotation mark with ``.


6>WKCAImageQueue.cpp
6>..\platform\graphics\win\WKCAImageQueue.cpp : error C2220: warning treated as error - no 'object' file generated
6>..\platform\graphics\win\WKCAImageQueue.cpp : warning C4819: The file contains a character that cannot be represented in the current code page (949). Save the file in Unicode format to prevent data loss

6>MediaPlayerPrivateFullscreenWindow.cpp
6>..\platform\graphics\win\MediaPlayerPrivateFullscreenWindow.cpp : error C2220: warning treated as error - no 'object' file generated
6>..\platform\graphics\win\MediaPlayerPrivateFullscreenWindow.cpp : warning C4819: The file contains a character that cannot be represented in the current code page (949). Save the file in Unicode format to prevent data loss
Comment 1 Kwang Yul Seo 2010-06-09 05:34:02 PDT
Created attachment 58236 [details]
Patch
Comment 2 Kent Tamura 2010-06-09 05:50:34 PDT

*** This bug has been marked as a duplicate of bug 40358 ***
Comment 3 David Levin 2010-06-09 08:59:45 PDT
Comment on attachment 58236 [details]
Patch

Already fixed in http://trac.webkit.org/changeset/60894 so I'm clearing the r?, etc.