Bug 40294 - Unexpectedly quit after upgrading to Safari 5
Summary: Unexpectedly quit after upgrading to Safari 5
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://gmail.com
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-08 05:56 PDT by Felipe Fermin
Modified: 2010-06-08 21:32 PDT (History)
1 user (show)

See Also:


Attachments
crash log is now attached in plain text file (41.13 KB, text/plain)
2010-06-08 12:54 PDT, Felipe Fermin
no flags Details
new crash log (70.70 KB, text/plain)
2010-06-08 21:16 PDT, Felipe Fermin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Fermin 2010-06-08 05:56:07 PDT
Unexpectedly quit while loading (for the 1st time after upgrading to Safari 5) macrumors.com, gmail.com and google apps gmail page.

After that, it just quit while attempting to load gmail.com.

Had to switch to Safari for the time being.
Comment 1 Alexey Proskuryakov 2010-06-08 12:34:14 PDT
Could you please attach a crash log, as described in <http://webkit.org/quality/crashlogs.html>?
Comment 2 Felipe Fermin 2010-06-08 12:54:08 PDT
Created attachment 58171 [details]
crash log is now attached in plain text file

I managed to reproduce the error. Webkit unexpectedly quits when pening 2 or more taps while 1st tab still was loading.

Maybe the problem is not necessarily with Gmail although Gmail was one the of the tabs that were opening this time around also.
Comment 3 Alexey Proskuryakov 2010-06-08 13:12:06 PDT
Thanks!

I'm going to blame unsupported "enhancers" until proven otherwise. Can you please remove Inquisitor, Chax and Menu Extra Enabler, and try again?

Resolving as INVALID, but please do re-open if this still happens with clean Safari.
Comment 4 Felipe Fermin 2010-06-08 13:51:35 PDT
Did not know I still had those! Will do!
Comment 5 Felipe Fermin 2010-06-08 21:16:47 PDT
Created attachment 58209 [details]
new crash log

Attaching new crash log. Bug persists. As sguggested, I removed all input managers that were still on my Mac for some reason, and I tried replicating the issue: After launching, while Webkit is still looking for the nightly builds homepage, I open new tabs: gmail, another google apps mail, and 2 other news sites, and Webkit is still becoming unresponsive and crashing (unexpectedly quitting) after a few beach ball seconds.
Comment 6 Alexey Proskuryakov 2010-06-08 21:24:08 PDT
I've seen this crash in bug 40292. Can you please try the newest nightly?
Comment 7 Felipe Fermin 2010-06-08 21:32:05 PDT
I just downloaded nightly build 60868 from Safari, I am amazed at how freakingly fast Webkit is now! Wow! Problem solved. Awesome work guys! Thanks a million! (Sorry for all the exclamation marks)