Bug 40288 - WebWorker spec not implemented correctly
: WebWorker spec not implemented correctly
Status: RESOLVED DUPLICATE of bug 25212
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript
: 528+ (Nightly build)
: Macintosh Intel Mac OS X 10.6
: P2 Normal
Assigned To: Nobody
Depends on:
  Show dependency treegraph
Reported: 2010-06-08 01:29 PDT by James
Modified: 2010-06-08 13:15 PDT (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description James 2010-06-08 01:29:08 PDT

"4.7.2 Dedicated workers and the Worker interface


This constructor must be visible when the script's global object is either a Window object or an object implementing the WorkerUtils interface."

It's only visible when the global object is Window so it's not possible to create nested workers.
Comment 1 Alexey Proskuryakov 2010-06-08 13:15:10 PDT
If you have a use case for nested workers, please comment in bug 22723. Currently, they are not being actively worked on, mainly because there doesn't seem to be any use for them, and implementation cost is rather high.

*** This bug has been marked as a duplicate of bug 25212 ***