Bug 40285 - [chromium] compile linux chromium in WebKit/out instead of WebKit/WebKit/chromium/out
Summary: [chromium] compile linux chromium in WebKit/out instead of WebKit/WebKit/chro...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Tony Chang
URL:
Keywords:
: 37969 (view as bug list)
Depends on: 40349
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 23:57 PDT by Tony Chang
Modified: 2010-07-14 13:10 PDT (History)
4 users (show)

See Also:


Attachments
Patch (4.37 KB, patch)
2010-06-07 23:58 PDT, Tony Chang
levin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Chang 2010-06-07 23:57:41 PDT
[chromium] compile linux chromium in WebKit/out instead of WebKit/WebKit/chromium/out
Comment 1 Tony Chang 2010-06-07 23:58:07 PDT
Created attachment 58117 [details]
Patch
Comment 2 Tony Chang 2010-06-08 00:03:47 PDT
Chromium Linux is currently built in WebKit/WebKit/chromium/out from a Makefile that is generated into WebKit/WebKit/chromium/Makefile.  This causes problems, because the Makefile that is generated builds relative paths to .cpp files.  This results in some files being compiled outside of the target directory.

For example, when building libwebcore.a, it places the file in WebKit/WebKit/chromium/out/WebCore/libwebcore.a instead of, say, WebKit/WebKit/chromium/out/Debug/obj.target/WebCore/libwebcore.a.  This causes problems because it tries to put the debug and release .a file in the same place and switching from debug to release can cause weird link errors.

Anyway, this patch is to move from generating WebKit/WebKit/chromium/Makefile to generating WebKit/Makefile.chromium and building at the root of the source tree.  Since this changes the output path, there's a small change to new-run-webkit-tests.
Comment 3 Tony Chang 2010-06-08 21:05:25 PDT
Committed r60878: <http://trac.webkit.org/changeset/60878>
Comment 4 WebKit Review Bot 2010-06-08 21:19:45 PDT
http://trac.webkit.org/changeset/60878 might have broken Chromium Linux Release
Comment 5 Tony Chang 2010-06-08 21:32:45 PDT
Reverted because this broke the linux build.
Comment 6 Tony Chang 2010-06-09 00:23:02 PDT
Committed r60884: <http://trac.webkit.org/changeset/60884>
Comment 7 Tony Chang 2010-06-09 00:40:49 PDT
(In reply to comment #6)
> Committed r60884: <http://trac.webkit.org/changeset/60884>

Yay, this actually worked.
Comment 8 Tony Chang 2010-07-14 13:10:50 PDT
*** Bug 37969 has been marked as a duplicate of this bug. ***