Bug 39923 - Web Inspector: [REGRESSION] caller locations are not shown on Timeline Panel.
Summary: Web Inspector: [REGRESSION] caller locations are not shown on Timeline Panel.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Feldman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-29 11:14 PDT by Pavel Feldman
Modified: 2010-05-29 16:34 PDT (History)
6 users (show)

See Also:


Attachments
[PATCH] Proposed fix. (4.09 KB, patch)
2010-05-29 11:25 PDT, Pavel Feldman
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Feldman 2010-05-29 11:14:00 PDT
A nasty regression that kills source locations for all records on timeline. I am reverting frontend changes made in http://trac.webkit.org/changeset/60083#file14 to fix it.
Comment 1 Pavel Feldman 2010-05-29 11:25:13 PDT
Created attachment 57413 [details]
[PATCH] Proposed fix.
Comment 2 jaimeyap 2010-05-29 13:14:24 PDT
WebCore/inspector/front-end/TimelinePanel.js: 
 +              contentHelper._appendLinkRow(WebInspector.UIString("Caller"), this.callerScriptName, callSite.lineNumber);


This would seem to be the bug right here.

this.callerScriptName is null. I believe it should instead be callsite.scriptName.

This may have been an issue with hand merging this file. 

@Pavel: I recall when you were landing it you said that timelinepanel.js had a conflict with another change that went in while https://bugs.webkit.org/show_bug.cgi?id=37502 was sitting in the commit queue. I believe that the merge had a small mistake.

Notice in https://bugs.webkit.org/attachment.cgi?id=56398&action=review the patch has the correct piece of code.

I recommend in stead of reverting, just try changing that one line and testing to see if the bug is resolved.
Comment 3 WebKit Commit Bot 2010-05-29 15:17:04 PDT
Comment on attachment 57413 [details]
[PATCH] Proposed fix.

Clearing flags on attachment: 57413

Committed r60412: <http://trac.webkit.org/changeset/60412>
Comment 4 WebKit Commit Bot 2010-05-29 15:17:15 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Pavel Feldman 2010-05-29 16:34:50 PDT
> Notice in https://bugs.webkit.org/attachment.cgi?id=56398&action=review the patch has the correct piece of code.
> 
> I recommend in stead of reverting, just try changing that one line and testing to see if the bug is resolved.

Yes. Sorry for this to sound like Jaime regressed it. Now it is clear to me that it was a poor merge on my side. Having said that, Jaime did have a small bug that was dropping callers for rendering events. Not from all of them though :P.

I reverted the change since I guess simply getting callserScriptName and line in the first line of formatting, was guaranteeing that old code was still functioning. So it is the shortest distance to the working code after the stack refactoring. The code still works and it works right, delta from the pre-stack state is just 4 lines!