Bug 39900 - [Qt] Presence of IcedTea Java plugin causes QtWebKit to crash...
Summary: [Qt] Presence of IcedTea Java plugin causes QtWebKit to crash...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P3 Major
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-05-28 14:10 PDT by Dawit A.
Modified: 2010-07-01 13:06 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dawit A. 2010-05-28 14:10:42 PDT
It was reported downstream that the latest package of icedtea plugin in Fedora 13, causes all QtWebKit based browsers to crash.
See https://bugs.kde.org/show_bug.cgi?id=234544 and https://bugs.kde.org/show_bug.cgi?id=238106 for details.

Since the Java applet support patch that was submitted here also crashes if certain NPAPI functions are not yet implemented, this issue can also be potentially related to the fix provided in https://bugs.webkit.org/show_bug.cgi?id=34539.
Comment 1 Balazs Kelemen 2010-06-04 05:40:24 PDT
Please specify an exact test case!
I tried google maps since the kde bug reports refer to that,
but I did not face with the bug.
I have ran the QtTestBrowser from WebKit trunk on an x86 32 bit system.
My java environment is:
> java -version
java version "1.6.0_17"
OpenJDK Runtime Environment (IcedTea6 1.7.3) (suse-2.1.1-i386)
OpenJDK Server VM (build 14.0-b16, mixed mode)
Comment 2 Dawit A. 2010-06-04 07:21:08 PDT
(In reply to comment #1)
> Please specify an exact test case!
> I tried google maps since the kde bug reports refer to that,
> but I did not face with the bug.
> I have ran the QtTestBrowser from WebKit trunk on an x86 32 bit system.
> My java environment is:
> > java -version
> java version "1.6.0_17"
> OpenJDK Runtime Environment (IcedTea6 1.7.3) (suse-2.1.1-i386)
> OpenJDK Server VM (build 14.0-b16, mixed mode)

I have asked one of the people that reported the ticket downstream to answer this question for you. I myself cannot reproduce this problem. No idea if this problem is x86_64 bit specific or even distro specific (Fedora) at this point...
Comment 3 Thomas Janssen 2010-06-04 09:32:57 PDT
Hi

Use konqueror or arora and simply surf to mail.google.com, wait a couple seconds and it crashes.

webkitpart-0.0.5-0.5.svn1129464.fc12.x86_64
arora-0.10.2-3.fc13.x86_64


java-1.6.0-openjdk-plugin-1.6.0.0-37.b17.fc13.x86_64

That's the working one, with 38.b18 crash.
Comment 4 Jędrzej Nowacki 2010-06-16 04:00:33 PDT
I can't reproduce it on Debian (32)
java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre2-1)
OpenJDK Server VM (build 14.0-b16, mixed mode)

ii  kpart-webkit                                0.9svn1084767-1                WebKit KPart
rc  konq-plugins                                4:3.5.9-2                      plugins for Konqueror, the KDE file/web/doc
ii  konqueror                                   4:4.3.4-1                      KDE 4's advanced file manager, web browser a
ii  konqueror-nsplugins                         4:4.3.4-1                      Netscape plugin support for Konqueror
ii  libkonq5                                    4:4.3.4-1                      core libraries for Konqueror
ii  libkonq5-templates                          4:4.3.4-1                      data files for the Konqueror libraries
ii  libkonqsidebarplugin4                       4:4.3.4-1                      Konqueror sidebar plugin library

Tested with QtTestBrowser from the WebKit's trunk and with Konqueror.
Comment 5 Thomas Janssen 2010-06-16 04:18:20 PDT
My bad. Konqueror here is from KDE SC 4.4.85

rpm -q kdebase
kdebase-4.4.85-1.fc13.x86_64

rpm -q qt
qt-4.7.0-0.16.beta1.fc13.x86_64
Comment 6 Balazs Kelemen 2010-06-16 04:42:09 PDT
I think we should set this bug to invalid.
Does any of you guys disagree with that?
Comment 7 Thomas Janssen 2010-06-16 05:01:15 PDT
Before you set it to invalid think about that it happens in qt 4.6.2 - 4.7.0.beta1, from KDE SC 4.4.2 - 4.4.85.

Following the latest working java here.

java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) 64-Bit Server VM (build 14.2-b01, mixed mode)

java-1.6.0-openjdk-1.6.0.0-37.b17.fc13.x86_64
Comment 8 Andras Becsi 2010-06-30 07:30:42 PDT
Since the issue could only be reproduced with Fedora packages, and noone commented on it for two weeks now, I'll set this invalid.
Comment 9 Rex Dieter 2010-06-30 08:36:38 PDT
Excuse me, but this problem only surfaced in recent builds of openjdk.  

Folks who couldn't reproduce this were using openjdk < b18.
Comment 10 Jędrzej Nowacki 2010-07-01 00:36:44 PDT
(In reply to comment #9)
> Excuse me, but this problem only surfaced in recent builds of openjdk.  
> 
> Folks who couldn't reproduce this were using openjdk < b18.

I can't reproduce it with konqueror (using webkit engine) and rekonq (trunk)
java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-1)
OpenJDK Server VM (build 14.0-b16, mixed mode)

and before I tried OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre2-1).

So I think it is Fedora related problem or we really need a better test case.
Comment 11 Rex Dieter 2010-07-01 05:42:04 PDT
OK, thanks for confirming/testing with b18.  I'll bounce this back to the openjdk maintainer(s) in fedora.
Comment 12 Thomas Janssen 2010-07-01 09:54:59 PDT
BTW, it is in Mandriva as well. Look at the first post (original bugreporter):

https://bugs.kde.org/show_bug.cgi?id=234544

Looks like not sooo invalid.
Comment 13 Andras Becsi 2010-07-01 12:03:37 PDT
(In reply to comment #12)
> BTW, it is in Mandriva as well. Look at the first post (original bugreporter):
> 
> https://bugs.kde.org/show_bug.cgi?id=234544
> 
> Looks like not sooo invalid.

This still doesn't prove that it is a WebKit bug.
Comment 14 Thomas Janssen 2010-07-01 13:05:59 PDT
(In reply to comment #13)
> (In reply to comment #12)
> > BTW, it is in Mandriva as well. Look at the first post (original bugreporter):
> > 
> > https://bugs.kde.org/show_bug.cgi?id=234544
> > 
> > Looks like not sooo invalid.
> 
> This still doesn't prove that it is a WebKit bug.

You're right. It's not just in Fedora as claimed, but it's no prove. I don't have the knowledge to load a backtrace into gdb and find out what happens for real (or whatever you guys do). TBH i slowly loose the interest in what might be the culprit. Changing back to KHTML and no crashes.

Thanks for.. the attention and time you spent reading this "bugreport".