Bug 39838 - [v8] Web Inspector: notify ScriptDebugListener when execution is resumed
Summary: [v8] Web Inspector: notify ScriptDebugListener when execution is resumed
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Yury Semikhatsky
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-27 07:44 PDT by Yury Semikhatsky
Modified: 2010-05-27 10:14 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.23 KB, patch)
2010-05-27 08:02 PDT, Yury Semikhatsky
no flags Details | Formatted Diff | Diff
Patch (1.52 KB, patch)
2010-05-27 09:59 PDT, Yury Semikhatsky
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2010-05-27 07:44:45 PDT
ScriptDebugListener::didContinue should be invoked when script execution is resumed.
Comment 1 Yury Semikhatsky 2010-05-27 08:02:13 PDT
Created attachment 57244 [details]
Patch
Comment 2 Pavel Feldman 2010-05-27 08:07:31 PDT
Comment on attachment 57244 [details]
Patch

WebCore/bindings/v8/ScriptDebugServer.cpp:307
 +  
Consider removing this blank line :)
Comment 3 Yury Semikhatsky 2010-05-27 08:16:35 PDT
Comment on attachment 57244 [details]
Patch

Clearing flags on attachment: 57244

Committed r60302: <http://trac.webkit.org/changeset/60302>
Comment 4 Yury Semikhatsky 2010-05-27 08:16:45 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Yury Semikhatsky 2010-05-27 09:56:16 PDT
We should check that the listener was not removed while messages were dispatched in the nested loop.
Comment 6 Yury Semikhatsky 2010-05-27 09:59:19 PDT
Created attachment 57253 [details]
Patch
Comment 7 Joseph Pecoraro 2010-05-27 10:12:01 PDT
That compiles? I've never been a fan of shadowing variables by reusing a variable name in an inner block. I realize this is v8 only, but you might want to consider changing the new variable name from "listener" to something else.
Comment 8 Yury Semikhatsky 2010-05-27 10:14:16 PDT
Committed r60309(In reply to comment #7)
> That compiles? I've never been a fan of shadowing variables by reusing a variable name in an inner block. I realize this is v8 only, but you might want to consider changing the new variable name from "listener" to something else.

I've already committed the patch as r60309. Will address your comment in one of the next patches.