Bug 39585 - Web Inspector: '?' and '/' typed at console prompt are not properly handled
Summary: Web Inspector: '?' and '/' typed at console prompt are not properly handled
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 39862 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-24 02:29 PDT by Andrey Kosyakov
Modified: 2010-05-28 03:20 PDT (History)
10 users (show)

See Also:


Attachments
patch (2.81 KB, patch)
2010-05-24 02:34 PDT, Andrey Kosyakov
yurys: review+
Details | Formatted Diff | Diff
patch (2.83 KB, patch)
2010-05-24 02:49 PDT, Andrey Kosyakov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Kosyakov 2010-05-24 02:29:53 PDT
'?' and '/' invoke help screen even when typed at console prompt.
Comment 1 Andrey Kosyakov 2010-05-24 02:34:53 PDT
Created attachment 56865 [details]
patch
Comment 2 Yury Semikhatsky 2010-05-24 02:40:50 PDT
Comment on attachment 56865 [details]
patch

WebCore/inspector/front-end/inspector.js:715
 +          event.preventDefault();
why not return from here?
Comment 3 Andrey Kosyakov 2010-05-24 02:49:22 PDT
Created attachment 56867 [details]
patch

Indeed, we better return instantly upon catching our key. Thanks for spotting this -- it's been so for quite a few revisions!
Comment 4 Alexey Proskuryakov 2010-05-24 12:36:24 PDT
> '?' and '/' invoke help screen even when typed at console prompt.

Why not mention that in ChangeLog? The current ChangeLog is super unhelpful - it tell neither what is fixed, nor how.
Comment 5 WebKit Commit Bot 2010-05-24 21:40:20 PDT
Comment on attachment 56867 [details]
patch

Clearing flags on attachment: 56867

Committed r60126: <http://trac.webkit.org/changeset/60126>
Comment 6 WebKit Commit Bot 2010-05-24 21:40:26 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Pavel Feldman 2010-05-28 03:20:55 PDT
*** Bug 39862 has been marked as a duplicate of this bug. ***