Bug 39568 - [Qt] Stuck in modal event loop on synchronous HTTP OPTIONS request
Summary: [Qt] Stuck in modal event loop on synchronous HTTP OPTIONS request
Status: RESOLVED DUPLICATE of bug 34647
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P3 Normal
Assignee: Nobody
URL: http://www.hulu.com
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-23 11:51 PDT by arvid2.nilsson
Modified: 2010-07-07 18:23 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arvid2.nilsson 2010-05-23 11:51:16 PDT
In ResourceHandleQt.cpp, ResourceHandle::loadResourceSynchronously.

The QNetworkReplyHandler constructor call to start() fails in Qt 4.6 when the HTTP method is OPTIONS, or any other unsupported method.

The surrounding code does not check the status of the newly created QNetworkReplyHandler, and goes on to enter a modal event loop waiting for completion of a network operation that was never started.

We are then stuck forever in this modal event loop.

Specific use case: synchronous XMLHttpRequest with OPTIONS verb as found when leaving a video playing on Hulu.com.
Comment 1 Andreas Kling 2010-07-07 18:23:29 PDT

*** This bug has been marked as a duplicate of bug 34647 ***