Bug 39248 - Using webkit-mask-box-image can cause "fringe" when transforming/rotating
Summary: Using webkit-mask-box-image can cause "fringe" when transforming/rotating
Status: RESOLVED DUPLICATE of bug 19179
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://panic.com/~cabel/bugs/mask1.html
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-17 16:10 PDT by Cabel Sasser
Modified: 2010-07-07 17:52 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cabel Sasser 2010-05-17 16:10:52 PDT
SUMMARY:
We are creating an element, filling it with a color, and using -webkit-mask-box-image to mask the element into a shape.

BUG:
Once rotated or transformed, pixel "fringe" shows up on the outside of the element, like a very thin border.
This is particularly painful when animating the element.

NOTES:
Load the provided reduced test case URL to see the problem.

- On top, see the 30deg rotated element. Notice that it appears to have a thin purple "border".
- On bottom, the same element without rotation. Note that there is no "border" or bounding box.
Comment 1 Simon Fraser (smfr) 2010-07-07 17:52:56 PDT

*** This bug has been marked as a duplicate of bug 19179 ***