Bug 38835 - list-style-image icons not displayed when list is broken up into columns
Summary: list-style-image icons not displayed when list is broken up into columns
Status: RESOLVED DUPLICATE of bug 23053
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://craiga.id.au/
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-10 01:23 PDT by Craig Anderson
Modified: 2014-02-17 20:16 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Anderson 2010-05-10 01:23:23 PDT
In the list at the bottom of http://craiga.id.au/ each list item has an list-style-image bullet specified.

This list is broken up into two columns using -webkit-column-count: 2;

These images seem to be accessed by WebKit (you can see them loaded through the web inspector), but aren't displayed.
Comment 1 Oli Studholme 2010-06-12 22:04:12 PDT
also ordered list numerals, and according to Bug 23053 unordered list bullets too
Comment 2 Oli Studholme 2010-06-12 22:09:03 PDT
(untested) workaround (works for default types like disc and decimal): list-style-position: inside; (Webkit default is presumably outside)
Comment 3 Craig Anderson 2010-06-13 23:22:38 PDT
Confirmed that list-style-position: inside workaround does work in this instance.
Comment 4 David Jones 2010-11-25 13:19:33 PST
I can also confirm that list-style-position: inside works as a workaround.
Comment 5 gur.trio 2014-02-17 20:16:25 PST

*** This bug has been marked as a duplicate of bug 23053 ***