Bug 38499 - css paged media :first pseudo-selector conflicts with sizzlejs / jquery
Summary: css paged media :first pseudo-selector conflicts with sizzlejs / jquery
Status: RESOLVED DUPLICATE of bug 38697
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-03 17:27 PDT by visnu pitiyanuvath
Modified: 2010-05-07 15:21 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description visnu pitiyanuvath 2010-05-03 17:27:01 PDT
r58385 introduced support for css paged media and the pseudo-selectors :left, :right, and :first. unfortunately, sizzlejs already uses the :first pseudo-selector to mean different semantics. sizzlejs is used in the jquery and dojo javascript libraries, which are extensively used on the web. in particular, sizzlejs assumes that browsers will throw an error when passed ":first" as a token to document.querySelectorAll [1].

I'm not sure who to file the bug against: sizzle or webkit. I'll file another bug against sizzle. if anything, expected behavior for webkit could be to still throw an exception if the :first pseudo-selector is found outside of an @page rule context.

[1] http://github.com/jeresig/sizzle/blob/master/sizzle.js#L920
Comment 1 visnu pitiyanuvath 2010-05-03 17:38:28 PDT
jquery bug filed here: http://dev.jquery.com/ticket/6519
Comment 2 visnu pitiyanuvath 2010-05-07 15:06:36 PDT
thinking I should post in radar to get more attention. ;)

*** This bug has been marked as a duplicate of bug 38697 ***
Comment 3 Alexey Proskuryakov 2010-05-07 15:21:39 PDT
Thanks for following up on this.

>thinking I should post in radar to get more attention. ;)

Sorry for having overlooked your earlier report. It's usually helpful to structure high importance bug reports like this around a specific user observable symptom (like "www.example.org no longer works in r12345 nightly"), as this gets more eyes looking at the issue.