Bug 38498 - [Qt] Crash stacktraces from the Qt release bots are not symbolized
Summary: [Qt] Crash stacktraces from the Qt release bots are not symbolized
Status: RESOLVED DUPLICATE of bug 33654
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2010-05-03 17:04 PDT by James Robinson
Modified: 2010-05-06 06:35 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Robinson 2010-05-03 17:04:58 PDT
Example: http://build.webkit.org/results/Qt%20Linux%20Release/r58712%20(11158)/fast/workers/worker-gc2-stderr.txt is:
Segmentation fault
0: /home/webkitbuildbot/slaves/release32bit/buildslave/qt-linux-release/build/WebKitBuild/Release/bin/DumpRenderTree [0x8069d55]
1: /home/webkitbuildbot/slaves/release32bit/buildslave/qt-linux-release/build/WebKitBuild/Release/bin/DumpRenderTree [0x806a0d8]
2: [0xf7fdb400]
3: /home/webkitbuildbot/slaves/release32bit/buildslave/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4 [0xf7ac5fb9]
4: /home/webkitbuildbot/slaves/release32bit/buildslave/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4 [0xf7ac9fa0]
5: /home/webkitbuildbot/slaves/release32bit/buildslave/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4 [0xf7a3f28e]
6: /home/webkitbuildbot/slaves/release32bit/buildslave/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4 [0xf7ac59a7]
7: /home/webkitbuildbot/slaves/release32bit/buildslave/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4 [0xf76c5e17]
8: /usr/local/Trolltech/Qt-4.6.0/lib/libQtCore.so.4(_ZN18QThreadStorageData6finishEPPv+0xa3) [0xf5f78df3]
9: /usr/local/Trolltech/Qt-4.6.0/lib/libQtCore.so.4 [0xf5f7a438]
10: /usr/local/Trolltech/Qt-4.6.0/lib/libQtCore.so.4 [0xf5f7a8e6]
11: /lib/libpthread.so.0 [0xf5ef7f3b]
12: /lib/libc.so.6(clone+0x5e) [0xf5d5dbee]

Can this be symbolized before uploading, please?  It would make these crashes much easier to diagnose.
Comment 1 Csaba Osztrogonác 2010-05-06 06:15:05 PDT

*** This bug has been marked as a duplicate of bug 33654 ***
Comment 2 Csaba Osztrogonác 2010-05-06 06:35:10 PDT
AFAIK fast/workers/worker-gc2 crash  was fixed by https://bugs.webkit.org/show_bug.cgi?id=38604 , but I haven't enough time to verify it.