Bug 38375 - Add codegen support for unsigned right shift
Summary: Add codegen support for unsigned right shift
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-29 23:04 PDT by Oliver Hunt
Modified: 2010-04-30 00:56 PDT (History)
1 user (show)

See Also:


Attachments
Patch (19.79 KB, patch)
2010-04-29 23:33 PDT, Oliver Hunt
barraclough: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Hunt 2010-04-29 23:04:24 PDT
Add codegen support for unsigned right shift
Comment 1 Oliver Hunt 2010-04-29 23:33:33 PDT
Created attachment 54785 [details]
Patch
Comment 2 WebKit Review Bot 2010-04-29 23:35:40 PDT
Attachment 54785 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--no-squash']" exit_code: 1
JavaScriptCore/assembler/MacroAssemblerARM.h:182:  shift_amount is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/MacroAssemblerX86Common.h:253:  shift_amount is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/X86Assembler.h:678:  shrl_i8r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/X86Assembler.h:688:  shrl_CLr is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/MacroAssemblerARMv7.h:261:  shift_amount is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 5 in 9 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Gavin Barraclough 2010-04-30 00:31:33 PDT
Comment on attachment 54785 [details]
Patch

r+ with comments in irc.
Comment 4 Oliver Hunt 2010-04-30 00:56:53 PDT
Committed r58562: <http://trac.webkit.org/changeset/58562>