Bug 38114 - DOM api does not work on SMIL animation
Summary: DOM api does not work on SMIL animation
Status: RESOLVED DUPLICATE of bug 34301
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL: http://svg.kvalitne.cz/mix/domapitoan...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-26 04:40 PDT by marek
Modified: 2010-05-10 01:33 PDT (History)
3 users (show)

See Also:


Attachments
testcase (474 bytes, image/svg+xml)
2010-04-26 04:40 PDT, marek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description marek 2010-04-26 04:40:03 PDT
Created attachment 54276 [details]
testcase

DOM API method  beginElement() is supposed to work with every SMIL object/animation.
It is working well on animate, set, animateTransform, but it fails in animateMotion.
Comment 1 Robin Cao 2010-05-06 00:27:39 PDT
The cause of this bug is that 'animateMotion' element has no js wrapper.
The following is line#16 of WebCore/svg/svgtags.in:
animateMotion JSInterfaceName=SVGElement, createWithNew

Is there any reason that we did not generate a wrapper for 'animateMotion'?
Comment 2 Dirk Schulze 2010-05-09 23:15:11 PDT
(In reply to comment #1)
> The cause of this bug is that 'animateMotion' element has no js wrapper.
> The following is line#16 of WebCore/svg/svgtags.in:
> animateMotion JSInterfaceName=SVGElement, createWithNew
> 
> Is there any reason that we did not generate a wrapper for 'animateMotion'?

I guess not. Am I wrong Niko?
Comment 3 Nikolas Zimmermann 2010-05-10 01:32:17 PDT
(In reply to comment #2)
> (In reply to comment #1)
> > The cause of this bug is that 'animateMotion' element has no js wrapper.
> > The following is line#16 of WebCore/svg/svgtags.in:
> > animateMotion JSInterfaceName=SVGElement, createWithNew
> > 
> > Is there any reason that we did not generate a wrapper for 'animateMotion'?
> 
> I guess not. Am I wrong Niko?

SVGAnimateMotionElement.idl is just missing. We have some bug report covering this, I have to look it up.
Comment 4 Nikolas Zimmermann 2010-05-10 01:33:51 PDT
Found it, please look at bug 34301. It's very easy to fix!

*** This bug has been marked as a duplicate of bug 34301 ***