Bug 38012 - REGRESSION: Ctrl- and Option- shortcuts get wrong keyCode on non-QWERTY keyboard
Summary: REGRESSION: Ctrl- and Option- shortcuts get wrong keyCode on non-QWERTY keyboard
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P1 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-22 16:13 PDT by Alexey Proskuryakov
Modified: 2010-04-22 17:09 PDT (History)
0 users

See Also:


Attachments
proposed fix (1.91 KB, patch)
2010-04-22 16:15 PDT, Alexey Proskuryakov
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2010-04-22 16:13:24 PDT
E.g. Ctrl+A on AZERTY keyboard reports VK_Q keycode, because the physical key is the same as Q on QWERTY.
Comment 1 Alexey Proskuryakov 2010-04-22 16:15:04 PDT
Created attachment 54104 [details]
proposed fix
Comment 2 Alexey Proskuryakov 2010-04-22 17:09:05 PDT
Committed <http://trac.webkit.org/changeset/58132>.