Bug 37918 - [GTK] Markup of copied non ASCII characters is broken
Summary: [GTK] Markup of copied non ASCII characters is broken
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Shinichiro Hamaji
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-21 04:42 PDT by Shinichiro Hamaji
Modified: 2010-05-05 23:23 PDT (History)
1 user (show)

See Also:


Attachments
test case (225 bytes, text/html)
2010-04-21 04:42 PDT, Shinichiro Hamaji
no flags Details
Patch v1 (2.64 KB, patch)
2010-04-21 04:46 PDT, Shinichiro Hamaji
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shinichiro Hamaji 2010-04-21 04:42:56 PDT
Created attachment 53943 [details]
test case

How to reproduce:

- Open the attached HTML with GtkLauncher
- Select more than 4 UTF8 characters in the HTML and copy it
- Paste it after "paste here:"
- You should see a string shorter than the original text

This is the reason why editing/pasteboard/copy-backslash-with-euc.html is failing.

I'll post a patch soon later.
Comment 1 Shinichiro Hamaji 2010-04-21 04:46:14 PDT
Created attachment 53944 [details]
Patch v1
Comment 2 Shinichiro Hamaji 2010-04-21 04:48:09 PDT
(In reply to comment #1)
> Created an attachment (id=53944) [details]
> Patch v1

FYI, this document doesn't say gtk_selection_data_set() takes the number of UTF8 characters as the length of data.

http://library.gnome.org/devel/gtk/stable/gtk-Selections.html#gtk-selection-data-set
Comment 3 Eric Seidel (no email) 2010-05-02 19:09:58 PDT
Comment on attachment 53944 [details]
Patch v1

It seems a comment in the code would be helpful here.
Comment 4 Eric Seidel (no email) 2010-05-02 19:10:29 PDT
LGTM, I dont' need to see this again, even if you add a comment.  If you want to cq it with changes, you can always use "webkit-patch land-safely".
Comment 5 Eric Seidel (no email) 2010-05-02 19:11:04 PDT
I'm not sure a comment is needed, but if you feel others might be confused by this API like the original author was, then please add one.
Comment 6 Eric Seidel (no email) 2010-05-02 19:31:41 PDT
Attachment 53944 [details] was posted by a committer and has review+, assigning to Shinichiro Hamaji for commit.
Comment 7 Shinichiro Hamaji 2010-05-05 23:06:35 PDT
It seemed this fix was done by this change: http://trac.webkit.org/changeset/58468

So, I'll just commit the change for the Skipped list.
Comment 8 Shinichiro Hamaji 2010-05-05 23:23:59 PDT
Committed r58866: <http://trac.webkit.org/changeset/58866>