Bug 37474 - Using arrow keys does not always move text cursor through CSS-generated content in editable div
Summary: Using arrow keys does not always move text cursor through CSS-generated conte...
Status: RESOLVED DUPLICATE of bug 10123
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2010-04-12 16:29 PDT by Nate Whetsell
Modified: 2011-11-03 13:47 PDT (History)
5 users (show)

See Also:


Attachments
Test document (374 bytes, text/html)
2010-04-12 16:29 PDT, Nate Whetsell
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Whetsell 2010-04-12 16:29:25 PDT
Created attachment 53194 [details]
Test document

Attached is a test HTML document with two tests related to editable divs that enclose a span that generates content with CSS.

The first test renders the following text:

xxx before span after yyy

Placing the text cursor before the first x and pressing the right arrow key will move the cursor to the right until it reaches the "b" in "before". If the cursor is placed in the word "span", pressing the right arrow key will move the cursor to the right until it reaches (the space before) the "a" in "after". Placing the text cursor after the last y and pressing the left arrow key does move the cursor fluidly through all text. Using [command + right arrow] or [shift + right arrow] will move the text cursor through the CSS-generated content. (However, when using shift the CSS content is selected as if it could be copied, which may be a separate issue.)

The second test renders the following text:

xxx
before span after yyy
 
The only difference is the line break after "xxx". In this case, placing the the text cursor before the first x and pressing the right arrow key will move the cursor onto the next line and into "span". However, using the left arrow key will not move the text cursor back into the previous line. Continuing to press the right arrow key will again move the cursor to the right until it reaches "after".
Comment 1 Nate Whetsell 2011-11-03 12:19:25 PDT
The last Mac OS X nightly build on which I can reproduce this issue is r97583.
Comment 2 Ryosuke Niwa 2011-11-03 13:47:45 PDT

*** This bug has been marked as a duplicate of bug 10123 ***