WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
37293
[WebKit2] Add Platform directory and files
https://bugs.webkit.org/show_bug.cgi?id=37293
Summary
[WebKit2] Add Platform directory and files
Sam Weinig
Reported
2010-04-08 15:03:03 PDT
Created
attachment 52898
[details]
Patch Start the dump of WebKit2.
Attachments
Patch
(111.69 KB, patch)
2010-04-08 15:03 PDT
,
Sam Weinig
andersca
: review+
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Adam Barth
Comment 1
2010-04-08 15:05:38 PDT
Is there a design doc for the structure of WebKit2? It's unclear to me how this relates to other ports.
WebKit Review Bot
Comment 2
2010-04-08 15:09:01 PDT
Attachment 52898
[details]
did not pass style-queue: Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1 Last 3072 characters of output: the same line [whitespace/newline] [4] WebKit2/Platform/CoreIPC/Attachment.h:58: More than one command on the same line [whitespace/newline] [4] WebKit2/Platform/CoreIPC/Attachment.h:61: More than one command on the same line [whitespace/newline] [4] WebKit2/Platform/CoreIPC/Attachment.h:62: More than one command on the same line [whitespace/newline] [4] WebKit2/Platform/CoreIPC/Attachment.h:63: More than one command on the same line [whitespace/newline] [4] WebKit2/Platform/CoreIPC/Attachment.h:64: More than one command on the same line [whitespace/newline] [4] WebKit2/Platform/win/RunLoopWin.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKit2/Platform/win/RunLoopWin.cpp:54: A case label should not be indented, but line up with its switch statement. [whitespace/indent] [4] WebKit2/Platform/win/WorkQueueWin.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKit2/Platform/CoreIPC/Attachment.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKit2/Platform/CoreIPC/Attachment.cpp:29: Alphabetical sorting problem. [build/include_order] [4] WebKit2/Platform/CoreIPC/Connection.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKit2/Platform/CoreIPC/Connection.cpp:38: Code inside a namespace should not be indented. [whitespace/indent] [4] WebKit2/Platform/CoreIPC/Connection.cpp:144: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebKit2/Platform/WorkQueue.h:37: "wtf/HashMap.h" already included at WebKit2/Platform/WorkQueue.h:31 [build/include] [4] WebKit2/Platform/CoreIPC/ArgumentDecoder.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKit2/Platform/CoreIPC/ArgumentDecoder.h:32: Alphabetical sorting problem. [build/include_order] [4] WebKit2/Platform/CoreIPC/ArgumentDecoder.h:41: Code inside a namespace should not be indented. [whitespace/indent] [4] WebKit2/Platform/CoreIPC/win/ConnectionWin.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKit2/Platform/CoreIPC/win/ConnectionWin.cpp:96: A case label should not be indented, but line up with its switch statement. [whitespace/indent] [4] WebKit2/Platform/CoreIPC/win/ConnectionWin.cpp:149: One line control clauses should not use braces. [whitespace/braces] [4] Total errors found: 42 in 24 files If any of these errors are false positives, please file a bug against check-webkit-style.
Dimitri Glazkov (Google)
Comment 3
2010-04-08 15:09:53 PDT
(In reply to
comment #1
)
> Is there a design doc for the structure of WebKit2? It's unclear to me how > this relates to other ports.
It's a new take on WebKit port design, so WebKit2 kinda seems reasonable.
Adam Barth
Comment 4
2010-04-08 15:11:53 PDT
I know. I was just giving Sam a hard time. :) Glad we have a meeting coming up. Should be fun to talk about.
Dimitri Glazkov (Google)
Comment 5
2010-04-08 15:13:45 PDT
(In reply to
comment #4
)
> I know. I was just giving Sam a hard time. :) > > Glad we have a meeting coming up. Should be fun to talk about.
I also think we should land in buildable chunks! :P
Adam Barth
Comment 6
2010-04-08 15:17:14 PDT
More seriously, we have some experience with this stuff. Are you interested in a real review, or is the plan to land the code in the tree, presuming it was reviewed internally by WebKit Reviewers (tm)?
Anders Carlsson
Comment 7
2010-04-08 15:22:01 PDT
(In reply to
comment #5
)
> (In reply to
comment #4
) > > I know. I was just giving Sam a hard time. :) > > > > Glad we have a meeting coming up. Should be fun to talk about. > > I also think we should land in buildable chunks! :P
This chunk is buildable! :)
Sam Weinig
Comment 8
2010-04-08 15:32:55 PDT
(In reply to
comment #6
)
> More seriously, we have some experience with this stuff. Are you interested in > a real review, or is the plan to land the code in the tree, presuming it was > reviewed internally by WebKit Reviewers (tm)?
Any feedback would be appreciated, but since we have the ok to land this (and have done internal review) we would like to land it and work iteratively in the Open Source from now on. Side note: this shouldn't break anyone since no one builds it.
Adam Barth
Comment 9
2010-04-08 15:41:29 PDT
Okiedokes. I can file bugs about anything I notice as the patches go by. You'd make me a happy man if you fixed the stylebot nits as you go, especially "Code inside a namespace should not be indented" because that one is a PITA to clean up incrementally.
Darin Adler
Comment 10
2010-04-08 16:57:04 PDT
Comment on
attachment 52898
[details]
Patch
> + std::queue<WorkItem*> workItemQueue;
There's already using namespace std, so just queue.
> + std::auto_ptr<WorkItem> item(workItemQueue.front());
And just auto_ptr.
> +void RunLoop::scheduleWork(std::auto_ptr<WorkItem> item)
And here. I'll review more later.
Anders Carlsson
Comment 11
2010-04-08 17:43:10 PDT
Comment on
attachment 52898
[details]
Patch r=me. (There are some minor style issues which we plan to fix once we land).
Adam Treat
Comment 12
2010-04-08 18:24:52 PDT
(In reply to
comment #11
)
> (From update of
attachment 52898
[details]
) > r=me. > > (There are some minor style issues which we plan to fix once we land).
This is a big no no for every other port introduction. It does not look good that you are landing this with style problems and without any community discussion before you've announced it today.
Sam Weinig
Comment 13
2010-04-08 19:08:48 PDT
Landed in
r57307
.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug