Bug 37198 - [Qt] Interrupting JavaScript is cumbersome when you use QtLaucher for testing or profiling.
Summary: [Qt] Interrupting JavaScript is cumbersome when you use QtLaucher for testing...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-07 03:25 PDT by Balazs Kelemen
Modified: 2010-04-21 06:33 PDT (History)
2 users (show)

See Also:


Attachments
proposed patch (6.28 KB, patch)
2010-04-07 03:33 PDT, Balazs Kelemen
no flags Details | Formatted Diff | Diff
fix a mistyping (6.29 KB, patch)
2010-04-07 03:38 PDT, Balazs Kelemen
no flags Details | Formatted Diff | Diff
GUI option instead of command line argument (5.67 KB, patch)
2010-04-08 08:09 PDT, Balazs Kelemen
hausmann: review+
Details | Formatted Diff | Diff
proposed patch (5.13 KB, patch)
2010-04-20 05:39 PDT, Balazs Kelemen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Balazs Kelemen 2010-04-07 03:25:55 PDT
Since we often use QtLauncher as a testing tool I think it would be better to turn off the shouldInterruptJavaScript feature in the launcher's WebPage.
Comment 1 Balazs Kelemen 2010-04-07 03:33:32 PDT
Created attachment 52723 [details]
proposed patch

This also fix the feature to start loading multiply url-s in different windows at startup.
Comment 2 Balazs Kelemen 2010-04-07 03:38:07 PDT
Created attachment 52725 [details]
fix a mistyping
Comment 3 Simon Hausmann 2010-04-08 06:58:08 PDT
No general objection from me, but why not automatically return true when in robot mode instead of requiring another commandline option?

Another idea would be to add a GUI option. On Symbian commandline options are not feasible ;(
Comment 4 Balazs Kelemen 2010-04-08 08:09:00 PDT
Created attachment 52867 [details]
GUI option instead of command line argument
Comment 5 Simon Hausmann 2010-04-19 17:40:15 PDT
Comment on attachment 52867 [details]
GUI option instead of command line argument

r+, but I think you can remove

+    WebPage(QObject* parent = 0, bool interruptingJavaScriptEnabled = false);

as you don't seem to call the constructor with that argument.

I'm generally not a fan of boolean arguments that make the caller code harder to read,
Comment 6 Balazs Kelemen 2010-04-20 05:39:48 PDT
Created attachment 53802 [details]
proposed patch

No boolean arguments :)
Comment 7 WebKit Commit Bot 2010-04-21 06:33:04 PDT
Comment on attachment 53802 [details]
proposed patch

Clearing flags on attachment: 53802

Committed r57974: <http://trac.webkit.org/changeset/57974>
Comment 8 WebKit Commit Bot 2010-04-21 06:33:10 PDT
All reviewed patches have been landed.  Closing bug.