Bug 37108 - Webkit crashes when loading this page multiple times with console on.
Summary: Webkit crashes when loading this page multiple times with console on.
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Critical
Assignee: Nobody
URL: http://www.amazon.com/dp/0974961043
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-05 13:14 PDT by michael@themcdaniels.net
Modified: 2010-04-06 13:38 PDT (History)
1 user (show)

See Also:


Attachments
Crash log (42.28 KB, text/plain)
2010-04-06 13:17 PDT, michael@themcdaniels.net
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description michael@themcdaniels.net 2010-04-05 13:14:25 PDT
Visit URL above.  Open web inspector with console.  Reload page a few times  Crashes without fail on both of my intel Macs (Macbook and Macbook Pro).
Comment 1 Alexey Proskuryakov 2010-04-05 16:13:51 PDT
I cannot reproduce this with a local debug build of r57018.

Which nightly build are you using? Please attach a crash log, <http://webkit.org/quality/crashlogs.html>.
Comment 2 michael@themcdaniels.net 2010-04-06 13:17:02 PDT
Created attachment 52660 [details]
Crash log
Comment 3 michael@themcdaniels.net 2010-04-06 13:18:04 PDT
I can no longer reproduce this since upgrading to 10.6.3.  Sorry for the inconvenience.

It still repros under Safari 4.0.5, though. Attached a crash log for that, in case you were interested.
Comment 4 Alexey Proskuryakov 2010-04-06 13:30:00 PDT
> I can no longer reproduce this since upgrading to 10.6.3.  Sorry for the
> inconvenience.

I'm confused - the attached crash says it's with 10.6.3.

The crash seems to be with shipping Safari/WebKit. Did you try a nightly WebKit build from http://nightly.webkit.org?
Comment 5 michael@themcdaniels.net 2010-04-06 13:35:12 PDT
Yes, I had seen it crashing some weeks ago even with the nightly (under 10.6.2), but must have mistakenly been using shipping Safari when I filed this.  My apologies.  The current nightly does not crash.  I will file this with Apple.  Please feel free to resolve.
Comment 6 Alexey Proskuryakov 2010-04-06 13:38:16 PDT
OK, thanks for the info. Please reference this bug if you file a report with Apple (which you can do if you want this to be fixed in shipping Safari/WebKit faster than it would happen normally).