Bug 37043 - Java regression tests spam stderr about being unable to set status message
Summary: Java regression tests spam stderr about being unable to set status message
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P3 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-02 13:55 PDT by Alexey Proskuryakov
Modified: 2010-04-02 14:22 PDT (History)
0 users

See Also:


Attachments
proposed patch (1.54 KB, patch)
2010-04-02 13:59 PDT, Alexey Proskuryakov
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2010-04-02 13:55:37 PDT
------------------------
- (void)webPlugInContainerShowStatus:(NSString *)message
{
...
    if (!_documentView) {
        LOG_ERROR("could not show status message (%@) because plug-in has already been destroyed", message);
        return;
    }
    WebView *v = [_dataSource _webView];
    [[v _UIDelegateForwarder] webView:v setStatusText:message];
------------------------

This code was added in <http://trac.webkit.org/changeset/6596>, I'm not sure why it is needed. And since then, it has degenerated into something that looks wrong (why test _documentView, and not _dataSource?)

Perhaps it can be just removed.
Comment 1 Alexey Proskuryakov 2010-04-02 13:59:44 PDT
Created attachment 52449 [details]
proposed patch
Comment 2 Alexey Proskuryakov 2010-04-02 14:22:01 PDT
Committed revision 57024.