Bug 36996 - ASSERT(m_isPrepared) hit in SQLiteStatement::step everytime I launch Safari on Windows
Summary: ASSERT(m_isPrepared) hit in SQLiteStatement::step everytime I launch Safari o...
Status: RESOLVED DUPLICATE of bug 37014
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows Vista
: P2 Major
Assignee: Dumitru Daniliuc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-01 17:44 PDT by Adele Peterson
Modified: 2010-04-02 10:07 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2010-04-01 17:44:53 PDT
m_query is SELECT name FROM sqlite_master WHERE type = 'table' AND name = 'IconInfo';

>	WebKit.dll!WebCore::SQLiteStatement::step()  Line 80 + 0x24 bytes	C++
 	WebKit.dll!WebCore::SQLiteDatabase::tableExists(const WebCore::String & tablename={IconInfo})  Line 206 + 0x8 bytes	C++
 	WebKit.dll!WebCore::isValidDatabase(WebCore::SQLiteDatabase & db={...})  Line 1050 + 0x1d bytes	C++
 	WebKit.dll!WebCore::IconDatabase::performOpenInitialization()  Line 1143 + 0xe bytes	C++
 	WebKit.dll!WebCore::IconDatabase::iconDatabaseSyncThread()  Line 989	C++
 	WebKit.dll!WebCore::IconDatabase::iconDatabaseSyncThreadStart(void * vIconDatabase=0x01dce1d8)  Line 942	C++
 	JavaScriptCore.dll!WTF::threadEntryPoint(void * contextData=0x01dcec10)  Line 65 + 0x9 bytes	C++
 	JavaScriptCore.dll!WTF::wtfThreadEntryPoint(void * param=0x01dcee80)  Line 206 + 0x9 bytes	C++
 	msvcr80.dll!_callthreadstartex()  Line 348 + 0x6 bytes	C
 	msvcr80.dll!_threadstartex(void * ptd=0x01dcef00)  Line 326 + 0x5 bytes	C
 	kernel32.dll!@BaseThreadInitThunk@12()  + 0x12 bytes	
 	ntdll.dll!___RtlUserThreadStart@8()  + 0x27 bytes	
 	ntdll.dll!__RtlUserThreadStart@8()  + 0x1b bytes
Comment 1 Dumitru Daniliuc 2010-04-01 18:28:58 PDT
I can't reproduce this problem on my machine. Let's try to debug this together tomorrow.
Comment 2 Adele Peterson 2010-04-02 10:06:53 PDT

*** This bug has been marked as a duplicate of bug 37014 ***
Comment 3 Adele Peterson 2010-04-02 10:07:31 PDT
Steve fixed this in http://trac.webkit.org/changeset/56978