Bug 36955 - check-webkit-style should support --git-index
Summary: check-webkit-style should support --git-index
Status: RESOLVED DUPLICATE of bug 27955
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P3 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-01 05:46 PDT by Hajime Morrita
Modified: 2010-04-01 17:57 PDT (History)
1 user (show)

See Also:


Attachments
patch v0 (9.40 KB, patch)
2010-04-01 05:53 PDT, Hajime Morrita
hamaji: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hajime Morrita 2010-04-01 05:46:00 PDT
check-webkit-style should support --git-index like prepare-ChangeLog does.
With --git-index, checker will inspect diff from git index.
Comment 1 Hajime Morrita 2010-04-01 05:53:52 PDT
Created attachment 52290 [details]
patch v0
Comment 2 Shinichiro Hamaji 2010-04-01 06:58:16 PDT
Comment on attachment 52290 [details]
patch v0

Thanks for your effort! However, I think this feature can confuse users. Please see the discussion in Bug 27955 for detail. Bug 35781 is also related. David's comment #9 in Bug 35781 would be super helpful to understand why it's difficult for us to support this syntax.
Comment 3 Shinichiro Hamaji 2010-04-01 06:58:31 PDT

*** This bug has been marked as a duplicate of bug 27955 ***
Comment 4 Hajime Morrita 2010-04-01 17:57:07 PDT
Hamaji-san, thank you for reviewing.
I should search bugzilla before file this... I'm sorry to bother you.