Bug 36888 - [REGRESSION] Inspector tests started crashing since r56829
Summary: [REGRESSION] Inspector tests started crashing since r56829
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-31 09:14 PDT by Yury Semikhatsky
Modified: 2010-03-31 10:02 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2010-03-31 09:14:10 PDT
Most of LayoutTests/inspector crash after http://trac.webkit.org/changeset/56829

Stack:
 	test_shell.exe!WebCore::V8Proxy::retrieveWindow(v8::Handle<v8::Context> context={...})  Line 537 + 0x2b bytes	C++
 	test_shell.exe!WebCore::State<WebCore::V8Binding>::getActiveWindow()  Line 53 + 0xf bytes	C++
>	test_shell.exe!WebCore::logPropertyAccess(v8::Local<v8::String> name={...}, const v8::AccessorInfo & info={...})  Line 152 + 0xc bytes	C++
 	test_shell.exe!WebCore::DOMWindowInternal::windowAttrGetter(v8::Local<v8::String> name={...}, const v8::AccessorInfo & info={...})  Line 633 + 0xd bytes	C++
 	test_shell.exe!v8::internal::Object::GetPropertyWithCallback(v8::internal::Object * receiver=0x06a6b295, v8::internal::Object * structure=0x008476f5, v8::internal::String * name=0x089ebec5, v8::internal::Object * holder=0x06a6b1d1)  Line 173 + 0x26 bytes	C++
 	test_shell.exe!v8::internal::Object::GetProperty(v8::internal::Object * receiver=0x06a6b295, v8::internal::LookupResult * result=0x002ed498, v8::internal::String * name=0x089ebec5, PropertyAttributes * attributes=0x002ed508)  Line 501 + 0x1d bytes	C++
 	test_shell.exe!v8::internal::Object::GetPropertyWithReceiver(v8::internal::Object * receiver=0x06a6b295, v8::internal::String * name=0x089ebec5, PropertyAttributes * attributes=0x002ed508)  Line 136 + 0x18 bytes	C++
 	test_shell.exe!v8::internal::Object::GetProperty(v8::internal::String * key=0x089ebec5, PropertyAttributes * attributes=0x002ed508)  Line 721	C++
 	test_shell.exe!v8::internal::Runtime::GetObjectProperty(v8::internal::Handle<v8::internal::Object> object={...}, v8::internal::Handle<v8::internal::Object> key={...})  Line 3057 + 0x1c bytes	C++
 	test_shell.exe!v8::internal::GetProperty(v8::internal::Handle<v8::internal::Object> obj={...}, v8::internal::Handle<v8::internal::Object> key={...})  Line 284 + 0x49 bytes	C++
 	test_shell.exe!v8::Object::Get(v8::Handle<v8::Value> key={...})  Line 2083 + 0x11 bytes	C++
 	test_shell.exe!WebCore::ScriptGlobalObject::get(WebCore::ScriptState * scriptState=0x06e8fcb8, const char * name=0x03300040, WebCore::ScriptObject & value={...})  Line 175	C++
 	test_shell.exe!WebCore::InspectorController::didEvaluateForTestInFrontend(long callId=0, const WebCore::String & jsonResult={...})  Line 1639 + 0x12 bytes	C++
 	test_shell.exe!WebCore::InspectorBackend::didEvaluateForTestInFrontend(long callId=0, const WebCore::String & jsonResult={...})  Line 439	C++
 	test_shell.exe!WebCore::InspectorBackendInternal::didEvaluateForTestInFrontendCallback(const v8::Arguments & args={...})  Line 518 + 0x1c bytes	C++
 	test_shell.exe!v8::internal::HandleApiCallHelper<0>(v8::internal::`anonymous-namespace'::BuiltinArguments<1> args={...})  Line 942 + 0x13 bytes	C++
 	test_shell.exe!v8::internal::Builtin_Impl_HandleApiCall(v8::internal::`anonymous-namespace'::BuiltinArguments<1> args={...})  Line 959 + 0xd bytes	C++
 	test_shell.exe!v8::internal::Builtin_HandleApiCall(v8::internal::`anonymous-namespace'::BuiltinArguments<1> args={...})  Line 958 + 0x18 bytes	C++
 	00db01ee()	
 	test_shell.exe!v8::internal::Invoke(bool construct=false, v8::internal::Handle<v8::internal::JSFunction> func={...}, v8::internal::Handle<v8::internal::Object> receiver={...}, int argc=3, v8::internal::Object * * * args=0x002edb70, bool * has_pending_exception=0x002eda6f)  Line 98 + 0x19 bytes	C++
 	test_shell.exe!v8::internal::Execution::Call(v8::internal::Handle<v8::internal::JSFunction> func={...}, v8::internal::Handle<v8::internal::Object> receiver={...}, int argc=3, v8::internal::Object * * * args=0x002edb70, bool * pending_exception=0x002eda6f)  Line 124 + 0x1f bytes	C++
 	test_shell.exe!v8::Function::Call(v8::Handle<v8::Object> recv={...}, int argc=3, v8::Handle<v8::Value> * argv=0x002edb70)  Line 2515 + 0x1d bytes	C++
 	test_shell.exe!WebKit::DebuggerAgentImpl::executeUtilityFunction(v8::Handle<v8::Context> context={...}, int callId=22, const char * object=0x04296108, const WebCore::String & functionName={...}, const WebCore::String & jsonArgs={...}, bool async=false, WebCore::String * exception=0x002edc3c)  Line 127 + 0x44 bytes	C++
 	test_shell.exe!WebKit::WebDevToolsAgentImpl::dispatchOnInspectorController(int callId=22, const WebCore::String & functionName={...}, const WebCore::String & jsonArgs={...})  Line 243 + 0x3a bytes	C++
 	test_shell.exe!WebKit::ToolsAgentDispatch::dispatch(WebKit::ToolsAgent * delegate=0x00cbc6cc, const WebKit::WebDevToolsMessageData & data={...})  Line 50 + 0x139 bytes	C++
 	test_shell.exe!WebKit::WebDevToolsAgentImpl::dispatchMessageFromFrontend(const WebKit::WebDevToolsMessageData & data={...})  Line 259 + 0x25 bytes	C++
 	test_shell.exe!TestShellDevToolsAgent::Call(const TestShellDevToolsCallArgs & args={...})  Line 86 + 0x13 bytes	C++
 	test_shell.exe!DispatchToMethod<TestShellDevToolsAgent,void (__thiscall TestShellDevToolsAgent::*)(TestShellDevToolsCallArgs const &),TestShellDevToolsCallArgs>(TestShellDevToolsAgent * obj=0x00cbddd0, void (const TestShellDevToolsCallArgs &)* method=0x018eff00, const Tuple1<TestShellDevToolsCallArgs> & arg={...})  Line 422 + 0xc bytes	C++
 	test_shell.exe!ScopedRunnableMethodFactory<TestShellDevToolsAgent>::RunnableMethod<void (__thiscall TestShellDevToolsAgent::*)(TestShellDevToolsCallArgs const &),Tuple1<TestShellDevToolsCallArgs> >::Run()  Line 153 + 0x1f bytes	C++
 	test_shell.exe!MessageLoop::RunTask(Task * task=0x0aaf5308)  Line 329 + 0xf bytes	C++
 	test_shell.exe!MessageLoop::DeferOrRunPendingTask(const MessageLoop::PendingTask & pending_task={...})  Line 340	C++
 	test_shell.exe!MessageLoop::DoWork()  Line 444 + 0xc bytes	C++
 	test_shell.exe!base::MessagePumpForUI::DoRunLoop()  Line 209 + 0x1d bytes	C++
 	test_shell.exe!base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate * delegate=0x002ef768, base::MessagePumpWin::Dispatcher * dispatcher=0x00000000)  Line 52 + 0xf bytes	C++
 	test_shell.exe!base::MessagePumpWin::Run(base::MessagePump::Delegate * delegate=0x002ef768)  Line 78 + 0x1c bytes	C++
 	test_shell.exe!MessageLoop::RunInternal()  Line 205 + 0x2a bytes	C++
 	test_shell.exe!MessageLoop::RunHandler()  Line 178	C++
 	test_shell.exe!MessageLoop::Run()  Line 156	C++
 	test_shell.exe!TestShell::WaitTestFinished()  Line 480 + 0xc bytes	C++
 	test_shell.exe!TestShell::RunFileTest(const TestShell::TestParams & params={...})  Line 289	C++
 	test_shell.exe!main(int argc=2, char * * argv=0x00d823e8)  Line 339 + 0xc bytes	C++
 	test_shell.exe!__tmainCRTStartup()  Line 327 + 0x19 bytes	C
 	test_shell.exe!mainCRTStartup()  Line 196	C
 	kernel32.dll!76d13677() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]	
 	ntdll.dll!77419d72() 	
 	ntdll.dll!77419d45()
Comment 1 Darin Fisher (:fishd, Google) 2010-03-31 09:47:04 PDT
It sounds like r56829 should be reverted.
Comment 2 Pavel Feldman 2010-03-31 09:52:40 PDT
(In reply to comment #1)
> It sounds like r56829 should be reverted.

Formally, it does not do anything wrong, but it relies upon calling context window that is absent since inspector uses utility context in the testing harness. It can affect more things, so I'd also prefer that we roll it out for now and land later when / if it does not break anything. Let me do that.
Comment 3 Pavel Feldman 2010-03-31 10:02:52 PDT
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	WebCore/ChangeLog
	M	WebCore/bindings/scripts/CodeGeneratorV8.pm
	M	WebCore/bindings/v8/V8Utilities.cpp
	M	WebCore/bindings/v8/V8Utilities.h
	M	WebCore/loader/FrameLoaderClient.h
	M	WebKit/chromium/ChangeLog
	M	WebKit/chromium/public/WebFrameClient.h
	M	WebKit/chromium/src/FrameLoaderClientImpl.cpp
	M	WebKit/chromium/src/FrameLoaderClientImpl.h
Committed r56849