Bug 36813 - LayoutTests/fast/dom/Window/window-resize.html fails on Mac if Dock is placed on the left
Summary: LayoutTests/fast/dom/Window/window-resize.html fails on Mac if Dock is placed...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Yuzo Fujishima
URL:
Keywords:
: 34310 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-30 02:21 PDT by Yuzo Fujishima
Modified: 2010-03-30 19:00 PDT (History)
1 user (show)

See Also:


Attachments
Fix LayoutTests/fast/dom/Window/window-resize.html (15.49 KB, patch)
2010-03-30 02:48 PDT, Yuzo Fujishima
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuzo Fujishima 2010-03-30 02:21:46 PDT
LayoutTests/fast/dom/Window/window-resize.html fails on Mac if Dock is placed on the left.

How to reproduce:
1. System Preferences -> Dock -> Position on screen -> Left
2. run-webkit-tests LayoutTests/fast/dom/Window/window-resize.html
3. Observe the test fails with diff similar to the following:

--- /tmp/layout-test-results/fast/dom/Window/window-resize-expected.txt	2010-03-30 18:19:18.000000000 +0900
+++ /tmp/layout-test-results/fast/dom/Window/window-resize-actual.txt	2010-03-30 18:19:18.000000000 +0900
@@ -7,7 +7,7 @@
 window.resizeTo Tests
 
 Testing - resizeTo: Too Big
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - resizeTo: Too Small
 PASS window.outerWidth is 100
@@ -16,11 +16,11 @@
 PASS window.screenY is screen.availTop
 PASS window.outerHeight is screen.availHeight
 PASS window.screenX is screen.availLeft
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - resizeTo: Not Full Screen Out of Bounds
 PASS window.outerHeight + window.screenY - screen.availTop is screen.availHeight
-PASS window.outerWidth + window.screenX - screen.availLeft is screen.width
+FAIL window.outerWidth + window.screenX - screen.availLeft should be 2560. Was 2503.
 
 window.resizeBy Tests
 
@@ -28,7 +28,7 @@
 PASS window.outerWidth is 100
 
 Testing - resizeBy: Too Big
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 window.moveTo Tests
 
@@ -42,15 +42,15 @@
 
 Testing - moveTo: Top Right
 PASS window.screenY is screen.availTop
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - moveTo: Right
 PASS window.screenY is screen.availTop
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - moveTo: Bottom Right
 PASS window.outerHeight is screen.availHeight
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - moveTo: Bottom
 PASS window.outerHeight is screen.availHeight
@@ -68,15 +68,15 @@
 
 Testing - moveBy: Zero Zero
 PASS window.screenY is 222
-PASS window.screenX is 200
+PASS window.screenX is 257
 
 Testing - moveBy: One Zero
 PASS window.screenY is 222
-PASS window.screenX is 201
+PASS window.screenX is 258
 
 Testing - moveBy: Zero One
 PASS window.screenY is 223
-PASS window.screenX is 201
+PASS window.screenX is 258
 
 Testing - moveBy: Top Left
 PASS window.screenY is screen.availTop
@@ -88,15 +88,15 @@
 
 Testing - moveBy: Top Right
 PASS window.screenY is screen.availTop
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - moveBy: Right
 PASS window.screenY is screen.availTop
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - moveBy: Bottom Right
 PASS window.outerHeight is screen.availHeight
-PASS window.outerWidth is screen.width
+FAIL window.outerWidth should be 2560. Was 2503.
 
 Testing - moveBy: Bottom
 PASS window.outerHeight is screen.availHeight
Comment 1 Kent Tamura 2010-03-30 02:42:11 PDT
*** Bug 34310 has been marked as a duplicate of this bug. ***
Comment 2 Yuzo Fujishima 2010-03-30 02:48:18 PDT
Created attachment 52017 [details]
Fix LayoutTests/fast/dom/Window/window-resize.html
Comment 3 Eric Seidel (no email) 2010-03-30 16:07:33 PDT
Comment on attachment 52017 [details]
Fix LayoutTests/fast/dom/Window/window-resize.html

That's amazing.
Comment 4 Yuzo Fujishima 2010-03-30 19:00:58 PDT
Committed r56821: <http://trac.webkit.org/changeset/56821>