Bug 36663 - Rename QTKit based media engine class name
Summary: Rename QTKit based media engine class name
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media Elements (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P2 Normal
Assignee: Eric Carlson
URL:
Keywords:
Depends on:
Blocks: 51249
  Show dependency treegraph
 
Reported: 2010-03-26 08:35 PDT by Eric Carlson
Modified: 2011-01-24 12:19 PST (History)
6 users (show)

See Also:


Attachments
Proposed patch (30.11 KB, patch)
2010-11-13 12:17 PST, Eric Carlson
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Carlson 2010-03-26 08:35:29 PDT
As noted in https://bugs.webkit.org/show_bug.cgi?id=36654, it is possible to use a GStreamer based media engine on OSX as well as the QTKit based media engine so we should use a non-generic class name.
Comment 1 Philippe Normand 2010-03-26 10:50:48 PDT
Additionnally I think it would be good to have a WTF_USE_... define to enable the QTKit player and same for QuickTime (or whatever is currently used on the windows port).
Comment 2 Tor Arne Vestbø (not active) 2010-09-28 09:23:20 PDT
Qt backends were renamed in <http://trac.webkit.org/changeset/68526>
Comment 4 Eric Carlson 2010-11-13 12:17:45 PST
Created attachment 73830 [details]
Proposed patch
Comment 5 Daniel Bates 2010-11-14 12:38:21 PST
Comment on attachment 73830 [details]
Proposed patch

Marking this attachment as a patch since it is a patch and it is flagged for review. Moreover, this will cause the EWS bots to build with this patch.
Comment 6 Eric Carlson 2010-11-16 10:30:15 PST
http://trac.webkit.org/changeset/72117
Comment 7 Ryosuke Niwa 2010-11-16 21:41:22 PST
This change might be responsible for some test failures:
http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r72115%20(20918)/results.html

All of the failures seem to be caused by failing to load some resource.  Could you look into this?
Comment 8 Ryosuke Niwa 2010-11-16 21:46:23 PST
(In reply to comment #7)
> This change might be responsible for some test failures:
> http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r72115%20(20918)/results.html
> 
> All of the failures seem to be caused by failing to load some resource.  Could you look into this?

Oops, this was a false alert.  The failure was caused by r72115, not r72117.  Sorry.
Comment 9 Eric Carlson 2010-11-16 21:49:02 PST
This changed the name of the OS X media engine class. The code change is *only* used by HTMLMediaElement, it has absolutely nothing to do with the loader.
Comment 10 Ademar Reis 2011-01-24 12:19:04 PST
Revision r68526 cherry-picked into qtwebkit-2.2 with commit 600bc9b <http://gitorious.org/webkit/qtwebkit/commit/600bc9b>