As noted in https://bugs.webkit.org/show_bug.cgi?id=36654, it is possible to use a GStreamer based media engine on OSX as well as the QTKit based media engine so we should use a non-generic class name.
Additionnally I think it would be good to have a WTF_USE_... define to enable the QTKit player and same for QuickTime (or whatever is currently used on the windows port).
Qt backends were renamed in <http://trac.webkit.org/changeset/68526>
http://trac.webkit.org/changeset/68526 might have broken Qt Windows 32-bit Debug
The following changes are on the blame list:
Created attachment 73830 [details]
Comment on attachment 73830 [details]
Marking this attachment as a patch since it is a patch and it is flagged for review. Moreover, this will cause the EWS bots to build with this patch.
This change might be responsible for some test failures:
All of the failures seem to be caused by failing to load some resource. Could you look into this?
(In reply to comment #7)
> This change might be responsible for some test failures:
> All of the failures seem to be caused by failing to load some resource. Could you look into this?
Oops, this was a false alert. The failure was caused by r72115, not r72117. Sorry.
This changed the name of the OS X media engine class. The code change is *only* used by HTMLMediaElement, it has absolutely nothing to do with the loader.
Revision r68526 cherry-picked into qtwebkit-2.2 with commit 600bc9b <http://gitorious.org/webkit/qtwebkit/commit/600bc9b>