Bug 36552 - Web Inspector: Ability to set the font size bigger
Summary: Web Inspector: Ability to set the font size bigger
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Enhancement
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-24 13:50 PDT by Mike Wilcox
Modified: 2012-08-24 23:14 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Wilcox 2010-03-24 13:50:16 PDT
Ability to set the font size bigger

The console messages are pretty small. While actually not bad for me, I imagine some have trouble. And when I do a presentation / examples using WebKit, I can't adjust the font size to be bigger for the monitor.
Comment 1 Diego Barros 2012-08-22 18:28:34 PDT
+1 for this also. The font is too small and would love to see this be configurable. Even if it was through a CSS file somewhere (given that that modification in a CSS file was not overwritten with each update).
Comment 2 Pavel Feldman 2012-08-22 22:08:16 PDT
Press Ctrl +/- (Cmd + / -).
Comment 3 Diego Barros 2012-08-22 22:19:41 PDT
I'm sorry that I wasn't clear. I did not mean the font on a web page you're viewing, I meant the font in the Web Inspector. 

For example, when I'm viewing HTML or JavaScript in the Web Inspector the font is too small. It would be great to be able to set (or increase) the font size there.
Comment 4 Pavel Feldman 2012-08-22 22:36:11 PDT
Yep. Just do that in the inspector window. It works at least in Chrome - it zooms inspector content itself.
Comment 5 Diego Barros 2012-08-22 22:37:10 PDT
But not in Safari, or the OS X WebKit Nightlies?
Comment 6 Diego Barros 2012-08-22 22:37:55 PDT
Thanks for the tip, but I was aware of it being possible in Chrome. Just not so in Safari.
Comment 7 Pavel Feldman 2012-08-22 22:39:43 PDT
Oh, ok, I'll take a look. Thanks for the heads up.
Comment 8 Diego Barros 2012-08-22 22:40:25 PDT
My apologies. I should have given more details, I should know better. Will do next time. :)
Comment 9 Pavel Feldman 2012-08-22 22:49:03 PDT
It works for me on WK1 (Safari prior to 5.1), so it is probably a WK2 issue. What is your Safari version? Btw, did you try undocking / docking the inspector window and pressing Cmd + / - in that mode?
Comment 10 Diego Barros 2012-08-22 22:53:07 PDT
I tried on Safari 6.0 (8536.25) and the latest WebKit nightly 6.0 (8536.25, 537+).

I did try it while the inspector is docked and undocked. When undocked, nothing happens. When docked, only the web page is increased/decreased, not the Web Inspector's content itself.
Comment 11 Pavel Feldman 2012-08-24 23:14:44 PDT
> I did try it while the inspector is docked and undocked. When undocked, nothing happens. When docked, only the web page is increased/decreased, not the Web Inspector's content itself.

Just checked it on Safari 6 with latest WebKit nightly - it works as intended. The only place it does not work is new Safari tools. New Safari inspector front-end has no relation to WebKit, please file the bug against Safari.