A method named "setAllowScrollersToOverlapContent:" was recently added as Mac-only SPI in WebFrame and WebDynamicScrollBarsView. This name should be "setAllows…" to match other usage. Also, parameters for -[WebDynamicScrollBarsView setAlwaysHideHorizontalScroller:] and -setAlwaysHideVerticalScroller: (which were added together with -setAllowScrollersToOverlapContent:) have reversed boolean-style names in the implementation, which is confusing.
Created attachment 50710 [details]
Patch to rename recently-added methods, instance variable, and parameters.
These methods are used only on Safari at this point. I will also update Safari for these renamings.
Committed in 55997.