Bug 36111 - [Qt] Improve the interactions when clicking on links on a touch screen
Summary: [Qt] Improve the interactions when clicking on links on a touch screen
Status: RESOLVED DUPLICATE of bug 44089
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Enhancement
Assignee: QtWebKit Unassigned
URL:
Keywords: Qt, QtTriaged
: 30712 33169 (view as bug list)
Depends on: 40197
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-15 02:28 PDT by Benjamin Poulain
Modified: 2010-08-18 08:28 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2010-03-15 02:28:08 PDT
Interaction with a touch screen is far less precise that with a mouse. When one clicks on a link with a finger, the single point of interaction is often not on the link.
QTouchPoint gives a rect representing the area of the finger on the screen. This rect must be used to find something the user can interact with.

To implement this task, QtWebkit needs to sample points in the rect, and find an element that will accepts a click.

The rect is not always available, here are the cases to handle:
-QTouchPoint has a rect
-QTouchEvent is sent, but without a rect -> guess a rect
-No QTouchEvent is sent, QMouseEvent is sent instead on a platform without mouse (Maemo, some Symbian, Windows Mobile) -> guess a rect if the platform is mobile
Comment 1 Kenneth Rohde Christiansen 2010-03-15 14:10:29 PDT
Antonio, your experience with the spatial navigation might come to use here. Maybe something smarter than sampling points.
Comment 2 Benjamin Poulain 2010-03-16 01:53:16 PDT
*** Bug 33169 has been marked as a duplicate of this bug. ***
Comment 3 Benjamin Poulain 2010-03-16 04:48:20 PDT
*** Bug 30712 has been marked as a duplicate of this bug. ***
Comment 4 Antonio Gomes 2010-03-27 08:52:10 PDT
(In reply to comment #1)
> Antonio, your experience with the spatial navigation might come to use here.
> Maybe something smarter than sampling points.

Right. I can certainly work on this after bug 29431, which targets on Monday on my schedule.
Comment 5 Benjamin Poulain 2010-03-27 12:23:47 PDT
(In reply to comment #4)
> Right. I can certainly work on this after bug 29431, which targets on Monday on
> my schedule.

If you think this will take more than a couple of days (and test with resistive and capacitive screens), please prioritize bug fixing instead.

If you think it can be easily done for WebKit 2.0, that would be great :)
Comment 6 nokiabugz 2010-05-03 07:37:21 PDT
Please note that this is also a problem with HTML elements other than links.  It takes several touch events to activate elements such as multiselect lists and buttons, as well as links.
Comment 7 Antonio Gomes 2010-08-18 08:28:50 PDT
Dup'ing it. This one will likely be fixed when bug 44089 is fixed.

*** This bug has been marked as a duplicate of bug 44089 ***