Patch coming to clean up a bunch of small bits, to be described in more detail on the patch itself.
Created attachment 50560 [details]
Details on the ChangeLog. Half of this is making things simpler, the other half is making things consistent between the different decoders.
Attachment 50560 [details] did not pass style-queue:
Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:144: num_bytes is incorrectly named. Don't use underscores in your identifier names. [readability/naming] 
Total errors found: 1 in 10 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 50561 [details]
It's always a judgment call which style issues in the JPEGImageDecoder file to fix; fixed this one because it's our member function rather than one of the C API functions libjpeg calls directly.
Comment on attachment 50561 [details]
Fixed in r56007.