Bug 35975 - REGRESSION: Crash in WebKitPluginHost due to Flash plugin
Summary: REGRESSION: Crash in WebKitPluginHost due to Flash plugin
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-03-10 09:48 PST by Dimitris Apostolou
Modified: 2010-03-11 06:16 PST (History)
2 users (show)

See Also:


Attachments
Crash log (31.57 KB, text/plain)
2010-03-10 09:48 PST, Dimitris Apostolou
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitris Apostolou 2010-03-10 09:48:15 PST
Created attachment 50411 [details]
Crash log

r55772

Reproducibility: always

Steps:
Open any page that includes Flash.

What happened:
Crash in WebKitPluginHost due to Flash plugin.

Expected result:
WebKitPluginHost does not crash.
Comment 1 John H. VanOphem 2010-03-10 11:53:49 PST
Happening to me as well. Uninstalled and re-installed Flash also.
Comment 2 Mark Rowe (bdash) 2010-03-10 15:17:16 PST
<rdar://problem/7740157>
Comment 3 Simon Fraser (smfr) 2010-03-10 16:21:26 PST
<rdar://problem/7739922>

I think this only happens if you have the Flash 10.1 beta installed.
Comment 4 John H. VanOphem 2010-03-10 16:40:41 PST
Yes, I have the latest beta installed
Comment 5 Simon Fraser (smfr) 2010-03-10 18:19:49 PST
http://trac.webkit.org/changeset/55824
Comment 6 Dimitris Apostolou 2010-03-11 06:16:26 PST
Verified with r55834.

Closing.