Bug 35963 - input type other than text won't work with autofill
Summary: input type other than text won't work with autofill
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Minor
Assignee: John Sullivan
URL: http://dag.bytestudios.com/test.html
Keywords:
Depends on: 35895
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-10 03:52 PST by John Sullivan
Modified: 2010-03-10 05:25 PST (History)
2 users (show)

See Also:


Attachments
Patch to make WebHTMLRepresentation elementDoesAutocomplete return true for any text fields other than passwords. (2.52 KB, patch)
2010-03-10 04:02 PST, John Sullivan
timothy: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Sullivan 2010-03-10 03:52:29 PST
+++ This bug was initially created as a clone of Bug #35895 +++

Unless I change my zipcode fields from input type="number" 
and my email fields from input type="email" to input type="text" 
autofill will not populate them
Comment 1 John Sullivan 2010-03-10 03:54:27 PST
The problem is in -[WebHTMLRepresentation elementDoesAutocomplete:], where only type TEXT is considered.
Comment 2 John Sullivan 2010-03-10 03:59:07 PST
I'll have a patch up later this morning.
Comment 3 John Sullivan 2010-03-10 04:02:16 PST
Created attachment 50388 [details]
Patch to make WebHTMLRepresentation elementDoesAutocomplete return true for any text fields other than passwords.
Comment 4 John Sullivan 2010-03-10 05:25:15 PST
http://trac.webkit.org/changeset/55776