Bug 35816 - CSS transition from fixed size to automatic size warps from 0 to desired
Summary: CSS transition from fixed size to automatic size warps from 0 to desired
Status: RESOLVED DUPLICATE of bug 16020
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-05 15:49 PST by Félix Cloutier
Modified: 2010-12-01 12:08 PST (History)
1 user (show)

See Also:


Attachments
The bugging (4.15 KB, text/html)
2010-03-05 15:49 PST, Félix Cloutier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Félix Cloutier 2010-03-05 15:49:05 PST
Created attachment 50135 [details]
The bugging 

Overview
When you create a CSS transition using -webkit-transition-property and -webkit-transition-duration to animate the width or the height of an image (or their min/max variants) from a fixed size to the auto value, the animation will go towards 0px and then warp to the necessary size instead of going directly to the necessary size.

Steps to reproduce:
Run the attached file and mouse over the huge title. Optionally, read the comments that have been left there.

Acutal results
The animation animates towards 0px and then jumps to the automatic size.

Expected results
The animation should animate towards the automatic size.
Comment 1 Simon Fraser (smfr) 2010-12-01 12:08:20 PST

*** This bug has been marked as a duplicate of bug 16020 ***