Bug 35473 - WebKit not initialising properly after crash
Summary: WebKit not initialising properly after crash
Status: UNCONFIRMED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-27 01:23 PST by Ain Tohvri
Modified: 2010-07-14 12:19 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ain Tohvri 2010-02-27 01:23:19 PST
Steps to reproduce:
1. If WebKit has crashed, click OK to send away the report
2. Click WebKit icon on the Dock to launch it
3. Program launches but remains loading the start page. Changing location bar to load any other page doesn't work either, stalls on loading.

It should be functional again once the report has been sent and Safari restarted.

Console log reveals:
27.02.10 11:17:01	Safari[12891]	WebKit failed to shut down cleanly.  Checking for Safari extensions.
27.02.10 11:17:01	Safari[12891]	WebKit r55270 initialized.

Workaround: close Safari and restart it once more.
Comment 1 Ain Tohvri 2010-05-29 03:09:42 PDT
The issue still persists in r60332. Safari just crashed over Debug Flash Player and it didn't load any pages after coming up again. Had to make another restart.
Comment 2 Ain Tohvri 2010-07-14 07:08:04 PDT
Issue still there in Safari version 5.0 (6533.16, r63285).
Comment 3 Mark Rowe (bdash) 2010-07-14 12:19:58 PDT
How long are you waiting for the page to load after a crash?