Bug 35427 - [Qt] Missing default controls for media element when loaded as stand alone document
Summary: [Qt] Missing default controls for media element when loaded as stand alone do...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media Elements (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P3 Normal
Assignee: QtWebKit Unassigned
URL: http://clips.vorwaerts-gmbh.de/big_bu...
Keywords: HTML5, Qt
: 29571 (view as bug list)
Depends on:
Blocks: 51543
  Show dependency treegraph
 
Reported: 2010-02-26 04:55 PST by Tor Arne Vestbø (not active)
Modified: 2011-01-28 11:50 PST (History)
3 users (show)

See Also:


Attachments
Patch (1.09 KB, patch)
2010-08-16 02:03 PDT, Tor Arne Vestbø (not active)
kenneth: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Arne Vestbø (not active) 2010-02-26 04:55:07 PST
When the url http://clips.vorwaerts-gmbh.de/big_buck_bunny.ogv is loaded as a separate document a mockup DOM is created with a single <video> element with the source set to http://clips.vorwaerts-gmbh.de/big_buck_bunny.ogv and controls="":

<html><body style="background-color: rgb(38,38,38);"><video controls="" autoplay="" style="margin: auto; position: absolute; top: 0; right: 0; bottom: 0; left: 0;" name="media" src="http://clips.vorwaerts-gmbh.de/big_buck_bunny.ogv"></video></body></html>

Safari and Chrome both show the built-in controls, QtWebKit does not.

May be related to how the built-in controls are not redrawn correctly when hovered unless the video is playing.
Comment 1 Tor Arne Vestbø (not active) 2010-03-15 04:54:30 PDT
*** Bug 29571 has been marked as a duplicate of this bug. ***
Comment 2 Tor Arne Vestbø (not active) 2010-08-16 02:03:08 PDT
Created attachment 64478 [details]
Patch
Comment 3 Tor Arne Vestbø (not active) 2010-08-17 04:44:44 PDT
Landed in r65492
Comment 4 Ademar Reis 2011-01-28 11:50:53 PST
Revision r65492 cherry-picked into qtwebkit-2.1.x with commit 1835fc6 <http://gitorious.org/webkit/qtwebkit/commit/1835fc6>