Bug 35208 - webkit-patch upload fails to upload large patches but does not report an error
Summary: webkit-patch upload fails to upload large patches but does not report an error
Status: RESOLVED DUPLICATE of bug 72863
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 58857 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-21 00:47 PST by Maciej Stachowiak
Modified: 2012-02-03 11:41 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2010-02-21 00:47:44 PST
If a patch is over the 2M patch limit on bugs.webkit.org, webkit-patch upload will fail to upload it but will not report an error. Instead it appears to succeed.

https://bugs.webkit.org/show_bug.cgi?id=35206 has an example of such a patch.
Comment 1 Adrienne Walker 2011-04-18 18:58:36 PDT
*** Bug 58857 has been marked as a duplicate of this bug. ***
Comment 2 Eric Seidel (no email) 2011-04-18 19:03:57 PDT
Sad times.  We should look at the bugzilla error code I guess.  I think we have similar trouble with misspelled CCs.
Comment 3 Eric Seidel (no email) 2011-04-18 19:19:54 PDT
This is very similar to bug 31760.

I suspect that the two places we need to check (and yell loudly) are:
http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/tool/steps/createbug.py#L52
http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/tool/steps/postdiff.py#L48

Possibly even returning or at least checking the result of browser.submit() here:
http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/net/bugzilla/bugzilla.py#L483
Comment 4 Eric Seidel (no email) 2012-02-03 11:41:37 PST
Duping this against bug 72863 since there has been more activity there.

*** This bug has been marked as a duplicate of bug 72863 ***