Bug 35024 - [GTK/Qt] Black text on black buttons using a dark theme
Summary: [GTK/Qt] Black text on black buttons using a dark theme
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: QtWebKit Unassigned
URL: http://bugs.webkit.org/
Keywords: Gtk, Qt, Regression
Depends on:
Blocks:
 
Reported: 2010-02-17 02:08 PST by calimeroteknik
Modified: 2011-01-07 14:06 PST (History)
5 users (show)

See Also:


Attachments
Patch (2.31 KB, patch)
2011-01-07 05:40 PST, Jan Erik Hanssen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description calimeroteknik 2010-02-17 02:08:42 PST
1. Set a dark Qt theme
2. go to http://bugs.webkit.org/ for instance

The buttons are unreadable, screenshot here :
http://www.kirikoo.net/images/14Anonyme-20100217-110456.png

Fix :
I suggest forcing the font color from the Qt theme to the button's font color.
Using dark themes, this will ensure white text on dark buttons, and using bright themes, black text on bright buttons.

No one will never have anymore problems after that, whatever his Qt theme. :)

Nota : the problem is the same using Webkit GTK
Comment 1 calimeroteknik 2010-02-17 02:17:55 PST
This is a regression. With Qt 4.5 everything was fine :

http://www.kirikoo.net/images/14Anonyme-20100217-111736.png
Comment 2 Tor Arne Vestbø 2010-03-05 09:39:46 PST
Please follow the QtWebKit bug reporting guidelines when reporting bugs.

See http://trac.webkit.org/wiki/QtWebKitBugs

Specifically:

  - The 'QtWebKit' component should be used for bugs/features in the public QtWebKit API layer, not to signify that the bug is specific to the Qt port of WebKit

    http://trac.webkit.org/wiki/QtWebKitBugs#Component
Comment 3 Robert Hogan 2010-03-16 11:29:53 PDT
I can reproduce this with QtLauncher.
Comment 4 calimeroteknik 2010-03-24 09:17:25 PDT
(In reply to comment #2)
>   - The 'QtWebKit' component should be used for bugs/features in the public
> QtWebKit API layer, not to signify that the bug is specific to the Qt port of
> WebKit

Like the problem is the same wth GTK, I posted here, but I should have posted twice in Qt and GTK.
Comment 5 Olivier Tilloy 2010-04-18 15:53:24 PDT
I reported bug #37779 to track this specific issue in the GTK port.
Comment 6 Jan Erik Hanssen 2011-01-07 05:40:44 PST
Created attachment 78226 [details]
Patch

Implement the same for Qt as added to GTK in bug 37779. Does this need a test case?
Comment 7 Andreas Kling 2011-01-07 05:55:53 PST
Comment on attachment 78226 [details]
Patch

Awesome, r=me
Comment 8 WebKit Commit Bot 2011-01-07 14:06:23 PST
Comment on attachment 78226 [details]
Patch

Clearing flags on attachment: 78226

Committed r75273: <http://trac.webkit.org/changeset/75273>
Comment 9 WebKit Commit Bot 2011-01-07 14:06:30 PST
All reviewed patches have been landed.  Closing bug.