Bug 34963 - iFrames transformed via -webkit-transform:scale are clipped incorrectly while Google Chrome correctly performs the transform
Summary: iFrames transformed via -webkit-transform:scale are clipped incorrectly while...
Status: RESOLVED DUPLICATE of bug 15676
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-15 15:34 PST by Neven Mrgan
Modified: 2010-03-12 21:06 PST (History)
9 users (show)

See Also:


Attachments
Example (249 bytes, text/html)
2010-02-15 15:34 PST, Neven Mrgan
no flags Details
Screenshot Safari vs Chrome (152.48 KB, image/png)
2010-03-11 08:34 PST, Thomas Steinacher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neven Mrgan 2010-02-15 15:34:04 PST
Created attachment 48780 [details]
Example

Applying a CSS transformation to an iFrame clips it incorrectly. A setting of -webkit-transform: scale(.5) will scale the entire iframe 50%, but it will then also further scale the clipping mask of the iframe's content by another 50%.

Attaching a reduced case.
Comment 1 Alexey Proskuryakov 2010-02-17 15:10:13 PST
Same as bug 15676, but with an actual test case?
Comment 2 Thomas Steinacher 2010-03-11 08:34:02 PST
Created attachment 50508 [details]
Screenshot Safari vs Chrome

Chrome renders correctly
Comment 3 Daniel Bates 2010-03-12 19:45:52 PST
Confirmed in Mac WebKit nightly r55891. Mac Chrome 5.0.307.11 beta seems to properly scale the <iframe> in the example.

Since Chrome appears to correctly scale the <iframe> and its contents, I believe this bug is a separate issue from the underlying transform issue described in bug #15676.

Thank you Neven Mrgan for the test case and Thomas Steinacher for the Safari Vs Chrome screen shot of the test case.
Comment 4 Daniel Bates 2010-03-12 19:57:33 PST
CC'ing Eric Seidel as he may have some insight into why this issue is not observed in Chrome/Chromium.
Comment 5 Eric Seidel (no email) 2010-03-12 20:29:52 PST
Chrome does not use hardware acceleration for transforms yet.  That may or may not be related to this issue.
Comment 6 Sam Weinig 2010-03-12 20:54:41 PST
This is almost certainly due to Mac WebKit using NSViews for iframes which do not transform properly.
Comment 7 Simon Fraser (smfr) 2010-03-12 21:06:07 PST

*** This bug has been marked as a duplicate of bug 15676 ***