Bug 34833 - Chromium DevTools: Trying to generate heap snapshots fast will generate more than expected
Summary: Chromium DevTools: Trying to generate heap snapshots fast will generate more ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Mikhail Naganov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-11 01:09 PST by Mikhail Naganov
Modified: 2010-02-11 12:50 PST (History)
1 user (show)

See Also:


Attachments
proposed fix (3.90 KB, patch)
2010-02-11 01:51 PST, Mikhail Naganov
pfeldman: review-
Details | Formatted Diff | Diff
make privates naming consistent with WebKit style (7.16 KB, patch)
2010-02-11 02:17 PST, Mikhail Naganov
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Naganov 2010-02-11 01:09:51 PST
What steps will reproduce the problem?
1. Open a webpage say http://www.google.com
2. Open Inspector(Ctrl+Shift+I)
3. Go to Profiles tab
4. Hit 'Take a snapshot button' fast, say 5 times

What is the expected output? 
To see 5 snapshots

What do you see instead?
Around 15 snapshots are being created
Comment 1 Mikhail Naganov 2010-02-11 01:51:40 PST
Created attachment 48552 [details]
proposed fix
Comment 2 Pavel Feldman 2010-02-11 01:58:38 PST
Comment on attachment 48552 [details]
proposed fix

Minor nits, otherwise r+.

> +    this.lastRequestedLogPosition_ = -1;

this._lastRequestedLogPosition

> + */
> +devtools.ProfilerAgent.prototype.getNextLogLines_ = function(immediately)
> +{

"Next" does not sound well with plurals. "Further"?

> +    if (this.lastRequestedLogPosition_ == this.logPosition_)

===

Now that the files are upstream, please fix naming of private fields.
Comment 3 Mikhail Naganov 2010-02-11 02:17:28 PST
Created attachment 48554 [details]
make privates naming consistent with WebKit style

please don't put into cq, I'll commit myself
Comment 4 Mikhail Naganov 2010-02-11 02:21:40 PST
(In reply to comment #2)
> (From update of attachment 48552 [details])
> Minor nits, otherwise r+.
> 
> > +    this.lastRequestedLogPosition_ = -1;
> 
> this._lastRequestedLogPosition
> 
> > + */
> > +devtools.ProfilerAgent.prototype.getNextLogLines_ = function(immediately)
> > +{
> 
> "Next" does not sound well with plurals. "Further"?

Google for "next lines". To me, it looks OK.

> 
> > +    if (this.lastRequestedLogPosition_ == this.logPosition_)
> 
> ===
> 
> Now that the files are upstream, please fix naming of private fields.

Fixed
Comment 5 Mikhail Naganov 2010-02-11 12:50:38 PST
Manually committed r54667: http://trac.webkit.org/changeset/54667