Bug 34828 - Microsoft Visual Studio 2008 (9.0) compatibility patch
Summary: Microsoft Visual Studio 2008 (9.0) compatibility patch
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-10 20:45 PST by Eugene Lavrenov
Modified: 2011-06-15 02:04 PDT (History)
5 users (show)

See Also:


Attachments
Patch (20.83 KB, application/octet-stream)
2010-02-10 21:02 PST, Eugene Lavrenov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Lavrenov 2010-02-10 20:45:21 PST
ChangeLog:
        These changes are required for building WebKit in new versions of Visual Studio with the same project setting: Treat Warnings As Errors /WX.

2010-02-10  Eugene Lavrenov  <evgenilv@yahoo.ca>

JavaScriptCore:
        Warning C4396: the inline specifier cannot be used when a friend declaration refers to a specialization of a function template.

        * wtf/HashSet.h:
        (WTF::deleteAllValues): removed inline specifier
        (WTF::fastDeleteAllValues): removed inline specifier

        * wtf/ListHashSet.h:
        (WTF::deleteAllValues): removed inline specifier

        * wtf/PassRefPtr.h:
        (WTF::adoptRef): removed inline specifier

WebKitTools:
        * Scripts/webkitdirs.pm: Added a msVisualStudioDir variable for easy transition to a new version of Visual Studio:
        my $msVisualStudioDir = "Microsoft Visual Studio 8"; # Change this for another version of Microsoft Visual Studio

The patch is attached. Please update the source. Obviously none of these changes affects functionality.
Comment 1 Eugene Lavrenov 2010-02-10 20:54:51 PST
It fixes bug 34804 as well.
Comment 2 Eugene Lavrenov 2010-02-10 21:02:01 PST
Created attachment 48545 [details]
Patch
Comment 3 Adam Roben (:aroben) 2010-02-11 07:12:30 PST
Comment on attachment 48545 [details]
Patch

You should check the "patch" checkbox and set the "review" flag to "?" if you want a patch to be reviewed.
Comment 4 Adam Roben (:aroben) 2010-02-11 07:13:29 PST
Comment on attachment 48545 [details]
Patch

Also, please attach your patch as a unified diff. See <http://webkit.org/coding/contributing.html> for instructions.
Comment 5 Adam Roben (:aroben) 2010-02-11 07:23:43 PST

*** This bug has been marked as a duplicate of bug 34804 ***
Comment 6 Adam Roben (:aroben) 2010-02-11 07:26:34 PST
Since the compiler warnings are already covered by bug 34804, let's make this bug only be about build-webkit not working with VS2008 and VS2010. Please split up your work to fix these issues into two separate patches. Thanks!
Comment 7 Adam Roben (:aroben) 2010-02-11 12:40:37 PST
Comment on attachment 48545 [details]
Patch

As previously requested, please upload a unified diff instead of a zip file, as described here: <http://webkit.org/coding/contributing.html>.

Also, please split this patch up into two pieces: one that fixes build-webkit (which should be attached to this bug), and one that fixes the compiler warnings (which should be attached to bug 34804).
Comment 8 Eugene Lavrenov 2010-02-11 13:20:45 PST
(In reply to comment #3)
> (From update of attachment 48545 [details])
> You should check the "patch" checkbox and set the "review" flag to "?" if you
> want a patch to be reviewed.
Done

(In reply to comment #4)
> (From update of attachment 48545 [details])
> Also, please attach your patch as a unified diff. See
> <http://webkit.org/coding/contributing.html> for instructions.
I am aware about the instructions, however, none of these scripts:
* run-webkit-tests
* prepare-ChangeLog
* svn-create-patch
works in my environment, regardless that I successfully checked out the code
using svn command as described here: http://webkit.org/building/checkout.html
You probably noticed that my e-mail account is on "yahoo.ca". It means that I
do not work for Apple, Google, Nokia, RIM or other corporate contributors of
WebKit project and of course I am NOT PAID for this work unlike most of you. I
cannot afford wasting too much time to fix the environment to generate a patch
in accordance to the instruction. The patch has all affected files in right
folders. If you copy a WebKit folder from a patch to your project, it will
substitute original files and make your project compliable in VS2008 and reduce
number of compiler errors for VS2010.

(In reply to comment #5)
> Since the compiler warnings are already covered by bug 34804, let's make this 
> bug only be about build-webkit not working with VS2008 and VS2010. Please split
> up your work to fix these issues into two separate patches. Thanks!
If it is possible I would prefer to leave the patch as is because:
1. There is no reason to flood your system with multiple attachments, which
will be the same
2. The patch is very simple.
3. It affects two projects JavaScriptCore and WebKitTools, but it is a turnkey
solution for compiling and building WebKit in VS2008.
Comment 9 Eric Seidel (no email) 2010-02-17 16:01:39 PST
Comment on attachment 48545 [details]
Patch

This is not a patch file, it's a zip.
Comment 10 Eric Seidel (no email) 2010-02-17 16:04:56 PST
For better or worse, with 30-50 patches coming in to webkit.org every day, and there only being 30 or so active reviewers (not all of which are paid, as you claim), we just can't handle exceptions to the process.

I recommend looking again at:
http://webkit.org/coding/contributing.html

If you're on windows, you'll need to look at:
http://webkit.org/building/tools.html

Adam Roben has always been very helpful to new windows contributers, but probably won't be very helpful if yelled at. :(

You might also find #webkit on irc.freenode.net helpful.  See:
http://webkit.org/contact.html
Comment 11 Gavin Barraclough 2011-06-15 02:04:37 PDT
These changes are now over 30,000 revisions out of date, and are still not a patch. :o)

Please feel free to attach an updated patch for review, but since the current changes clearly wouldn't cleanly apply to ToT I'm closing this bug for now.

cheers,
G.