Bug 34807 - Word wrapping incorrect when using quotes after question mark
Summary: Word wrapping incorrect when using quotes after question mark
Status: RESOLVED DUPLICATE of bug 17475
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Major
Assignee: Nobody
URL: http://beyondtheorylogistics.com/why
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-10 11:12 PST by Jacob Page
Modified: 2010-02-11 12:23 PST (History)
1 user (show)

See Also:


Attachments
What the incorrect word wrapping looks like. (1.95 KB, image/png)
2010-02-10 11:12 PST, Jacob Page
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Page 2010-02-10 11:12:00 PST
Created attachment 48511 [details]
What the incorrect word wrapping looks like.

This bug was originally posted to the Chromium issue tracker, but I brought it here because somebody reported the same issue in Safari.

I have some elements in my HTML that contain quotations that end with 
question marks, i.e.:

      <blockquote>
        &ldquo;Is &lsquo;hiding&rsquo; the real prices a sign of trust and 
        partnership?&rdquo;
      </blockquote>

In Chrome, the quote character after the question mark is wrapping to the 
next line.  This happens for ", &rdquo;, and even '.  The other browsers do 
the right thing and keep the question mark and quote fixed to the last word 
of the sentence.  I experienced this with blockquotes, but I verified the 
same thing happens for paragraphs.

At this moment, you can see the bug in action at http://beyondtheorylogistics.com/why.

Chrome Version: 4.0.249.78
Other browsers tested:
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK
Comment 1 Alexey Proskuryakov 2010-02-11 12:23:08 PST
This is already fixed.

*** This bug has been marked as a duplicate of bug 17475 ***