Bug 34696 - Text in textarea tag looks garbled
Summary: Text in textarea tag looks garbled
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 525.x (Safari 3.2)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2010-02-07 22:56 PST by Jayakrishnan
Modified: 2017-06-06 21:56 PDT (History)
4 users (show)

See Also:


Attachments
A test html file to reproduce the issue filed (213 bytes, text/html)
2010-02-07 22:58 PST, Jayakrishnan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jayakrishnan 2010-02-07 22:56:12 PST
Text typed inside a <textarea> looks garbled (i.e., some kind of painting issue upon typing inside the textarea, when the space key is pressed 
the typed word appears properly). The textarea is positioned "absolute" inside a container whose position is "relative".

Steps to Reproduce:

1. Open the attached safari.html file in Safari.

2. Scroll the container such that the textarea inside scrolls to view.

3. Focus the textarea and type some text. You can see the text is garbled and becomes normal after sometime.

Is there any fix available for this issue?

My system configuration is Mac OS X 10.5.8 and Safari is 4.0.2. The same issue is reproducible in Windows Safari.

Thanks
Jayakrishnan
Comment 1 Jayakrishnan 2010-02-07 22:58:13 PST
Created attachment 48320 [details]
A test html file to reproduce the issue filed
Comment 2 Jayakrishnan 2010-02-11 00:59:22 PST
Expecting a response for this bug. Thanks in advance.
Comment 3 Mark Rowe (bdash) 2010-02-11 01:10:45 PST
<rdar://problem/7637311>
Comment 4 Jayakrishnan 2010-02-11 01:37:58 PST
Can i know the reason for "HasReduction" keyword being assigned? coz the issue is easily reproducible in Safari.

Also, its been acknowledged it here...

http://discussions.apple.com/thread.jspa?threadID=2316950&tstart=0
Comment 5 Deirdre Saoirse Moen 2010-02-11 14:08:25 PST
HasReduction simply means there is a reduced test case that demonstrates the issue. Thank you for that.
Comment 6 Robert Hogan 2013-04-01 05:33:27 PDT
I can't recreate this on Chrome with WebKit r146919. Are you still seeing the issue in Safari?
Comment 7 Jon Lee 2017-06-06 21:56:45 PDT
No longer can reproduce.