Bug 34655 - [chromium] Change chromium interface to handle DownloadURL format.
Summary: [chromium] Change chromium interface to handle DownloadURL format.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Jian Li
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-05 11:12 PST by Jian Li
Modified: 2010-02-07 04:35 PST (History)
3 users (show)

See Also:


Attachments
Proposed Patch (4.79 KB, patch)
2010-02-05 11:14 PST, Jian Li
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jian Li 2010-02-05 11:12:19 PST
Now the value of DownloadURL format is a string containing a list of values. So we need to change the chromium interface for it. In order not to break the existing stuff, I will first add the new member in this patch. Later on when chromium side change is committed, I will remove the obsolete member.
Comment 1 Jian Li 2010-02-05 11:14:32 PST
Created attachment 48244 [details]
Proposed Patch
Comment 2 Darin Fisher (:fishd, Google) 2010-02-06 12:35:49 PST
Comment on attachment 48244 [details]
Proposed Patch

> +++ b/WebCore/platform/chromium/ChromiumDataObject.cpp
> @@ -38,6 +38,7 @@ void ChromiumDataObject::clear()
>      url = KURL();
>      urlTitle = "";
>      downloadURL = KURL();
> +    downloadMetadata = "";

nit: should be "downloadMetaData" <-- cap "Data"


> +++ b/WebKit/chromium/public/WebDragData.h
> @@ -74,6 +74,8 @@ public:
>  
>      WEBKIT_API WebURL downloadURL() const;
>      WEBKIT_API void setDownloadURL(const WebURL&);
> +    WEBKIT_API WebString downloadMetadata() const;
> +    WEBKIT_API void setDownloadMetadata(const WebString&);

same nit: should be named downloadMetaData and setDownloadMetaData


otherwise, this LGTM
Comment 3 Darin Fisher (:fishd, Google) 2010-02-06 12:37:23 PST
Actually, I take it back.  http://en.wikipedia.org/wiki/Metadata seems to strongly favor the spelling you used.  I had always thought of it as two words combined meta plus data, but I guess I was wrong.
Comment 4 Darin Fisher (:fishd, Google) 2010-02-06 12:38:08 PST
Comment on attachment 48244 [details]
Proposed Patch

R=me (I'm also doing CQ+ since this shouldn't break the Chromium build.)
Comment 5 WebKit Commit Bot 2010-02-07 04:35:42 PST
Comment on attachment 48244 [details]
Proposed Patch

Clearing flags on attachment: 48244

Committed r54469: <http://trac.webkit.org/changeset/54469>
Comment 6 WebKit Commit Bot 2010-02-07 04:35:50 PST
All reviewed patches have been landed.  Closing bug.