Bug 34635 - [Qt] When QWebView has a different style set on it then the scrollbars are not rendered correctly
Summary: [Qt] When QWebView has a different style set on it then the scrollbars are no...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 525.x (Safari 3.2)
Hardware: PC OS X 10.5
: P3 Normal
Assignee: Alexis Menard (darktears)
URL:
Keywords: Qt, QtTriaged
: 35681 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-05 01:44 PST by qt-info
Modified: 2011-05-25 07:28 PDT (History)
4 users (show)

See Also:


Attachments
Fix for the problem (1.45 KB, patch)
2010-02-05 01:44 PST, qt-info
no flags Details | Formatted Diff | Diff
Patch (2.57 KB, patch)
2011-05-23 12:54 PDT, Alexis Menard (darktears)
no flags Details | Formatted Diff | Diff
Patch (2.72 KB, patch)
2011-05-24 09:38 PDT, Alexis Menard (darktears)
no flags Details | Formatted Diff | Diff
Patch (2.70 KB, patch)
2011-05-24 10:33 PDT, Alexis Menard (darktears)
tonikitoo: review+
tonikitoo: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description qt-info 2010-02-05 01:44:01 PST
Created attachment 48211 [details]
Fix for the problem

When QWebView has a different style set on it then the scrollbars are not rendered correctly on the Mac, only the buttons are rendered but not the actual slider.

This can reproduced with the demo Qt browser and running it with a style such as plastique.
Comment 1 Tor Arne Vestbø (not active) 2010-03-10 06:40:42 PST
Please follow the QtWebKit bug reporting guidelines when reporting bugs.

See http://trac.webkit.org/wiki/QtWebKitBugs

Specifically:

  - The 'QtWebKit' component should only be used for bugs/features in the
    public QtWebKit API layer, not to signify that the bug is specific to
    the Qt port of WebKit

      http://trac.webkit.org/wiki/QtWebKitBugs#Component

  - Add the keyword 'Qt' to signal that it's a Qt-related bug

      http://trac.webkit.org/wiki/QtWebKitBugs#Keywords
Comment 2 Alexis Menard (darktears) 2011-05-23 12:54:29 PDT
Created attachment 94467 [details]
Patch
Comment 3 Alexis Menard (darktears) 2011-05-23 12:57:44 PDT
*** Bug 35681 has been marked as a duplicate of this bug. ***
Comment 4 Benjamin Poulain 2011-05-24 09:09:35 PDT
Comment on attachment 94467 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=94467&action=review

> Source/WebCore/platform/qt/ScrollbarThemeQt.cpp:159
> +    if (qobject_cast<QMacStyle *>(QApplication::style()))

Application::style()? What if the widget has a different style than the default style?
Comment 5 Alexis Menard (darktears) 2011-05-24 09:38:05 PDT
Created attachment 94628 [details]
Patch
Comment 6 Alexis Menard (darktears) 2011-05-24 10:33:02 PDT
Created attachment 94641 [details]
Patch
Comment 7 Antonio Gomes 2011-05-24 21:58:11 PDT
Comment on attachment 94641 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=94641&action=review

> Source/WebCore/ChangeLog:9
> +        two paths one for Mac and one for any other styles. The problem is that on Mac you can still run the

needs a comma after "two paths"

> Source/WebCore/platform/qt/ScrollbarThemeQt.cpp:161
> +    if (qobject_cast<QMacStyle *>(style()))

unneeded space.

> Source/WebCore/platform/qt/ScrollbarThemeQt.cpp:170
> +        // The QStyle expects the background to be already filled

missing dot in the end.
Comment 8 Alexis Menard (darktears) 2011-05-25 04:39:53 PDT
Committed r87290: <http://trac.webkit.org/changeset/87290>
Comment 9 Ademar Reis 2011-05-25 07:28:06 PDT
Revision r87290 cherry-picked into qtwebkit-2.2 with commit 5087eaa <http://gitorious.org/webkit/qtwebkit/commit/5087eaa>