Bug 34572 - [Gtk] Implement layoutTestController.pageNumberForElementById
Summary: [Gtk] Implement layoutTestController.pageNumberForElementById
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Shinichiro Hamaji
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-04 03:59 PST by Shinichiro Hamaji
Modified: 2010-02-05 21:38 PST (History)
5 users (show)

See Also:


Attachments
Patch v1 (5.49 KB, patch)
2010-02-04 04:01 PST, Shinichiro Hamaji
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shinichiro Hamaji 2010-02-04 03:59:17 PST
This was added in Bug 33840.
Comment 1 Shinichiro Hamaji 2010-02-04 04:01:06 PST
Created attachment 48131 [details]
Patch v1
Comment 2 WebKit Review Bot 2010-02-04 04:04:33 PST
Attachment 48131 [details] did not pass style-queue:

Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
WebKitTools/DumpRenderTree/gtk/LayoutTestControllerGtk.cpp:58:  webkit_web_frame_page_number_for_element_by_id is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit/gtk/webkit/webkitwebframe.cpp:854:  Use 0 instead of NULL.  [readability/null] [5]
Total errors found: 2


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Shinichiro Hamaji 2010-02-04 04:24:24 PST
(In reply to comment #2)
> Attachment 48131 [details] did not pass style-queue:
> 
> Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
> WebKitTools/DumpRenderTree/gtk/LayoutTestControllerGtk.cpp:58: 
> webkit_web_frame_page_number_for_element_by_id is incorrectly named. Don't use
> underscores in your identifier names.  [readability/naming] [4]
> WebKit/gtk/webkit/webkitwebframe.cpp:854:  Use 0 instead of NULL. 
> [readability/null] [5]
> Total errors found: 2

Looks like these files should be in the exception list of our style checker?
Comment 4 Gustavo Noronha (kov) 2010-02-05 03:52:53 PST
Comment on attachment 48131 [details]
Patch v1

I was going to say the function name lacked a 'get' somewhere, to be consistent, but I see we have previous cases of that; we might want to review all of them while exposing. Thanks for the patch!
Comment 5 Gustavo Noronha (kov) 2010-02-05 03:53:49 PST
(In reply to comment #3)
> (In reply to comment #2)
> > Attachment 48131 [details] [details] did not pass style-queue:
> > 
> > Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
> > WebKitTools/DumpRenderTree/gtk/LayoutTestControllerGtk.cpp:58: 
> > webkit_web_frame_page_number_for_element_by_id is incorrectly named. Don't use
> > underscores in your identifier names.  [readability/naming] [4]
> > WebKit/gtk/webkit/webkitwebframe.cpp:854:  Use 0 instead of NULL. 
> > [readability/null] [5]
> > Total errors found: 2
> 
> Looks like these files should be in the exception list of our style checker?

Indeed. Rules here should be the same as for WebKit/gtk/
Comment 6 Eric Seidel (no email) 2010-02-05 12:03:04 PST
Attachment 48131 [details] was posted by a committer and has review+, assigning to Shinichiro Hamaji for commit.
Comment 7 Shinichiro Hamaji 2010-02-05 21:38:11 PST
Comment on attachment 48131 [details]
Patch v1

Clearing flags on attachment: 48131

Committed r54461: <http://trac.webkit.org/changeset/54461>
Comment 8 Shinichiro Hamaji 2010-02-05 21:38:21 PST
All reviewed patches have been landed.  Closing bug.