Bug 34568 - 2x execCommand ReadAV@NULL
Summary: 2x execCommand ReadAV@NULL
Status: RESOLVED DUPLICATE of bug 35791
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows Vista
: P1 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-04 02:07 PST by Berend-Jan Wever
Modified: 2010-04-06 22:47 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Berend-Jan Wever 2010-02-04 02:07:38 PST
Repro:

<BODY></BODY>
<SCRIPT>
  document.designMode = "on";
  document.execCommand("selectall");
  document.execCommand("InsertLineBreak");
  document.execCommand("InsertLineBreak");
  document.execCommand("forecolor", false, 1); // Optional, see note
  document.execCommand("InsertText", false, 1);
  document.execCommand("SelectAll");
  document.execCommand("createlink", false, 1);
  document.execCommand("justifycenter", false);
</SCRIPT>

The "forecolor" line is optional: there are two different crashes that can 
happen, one with it and one without (latest non-debug build of Chromium):

WebCore::Node::shadowAncestorNode ReadAV@NULL 
(3b90161564d80c611251f74d8780bd91)
WebCore::CSSStyleDeclaration::diff ReadAV@NULL 
(2b02a76b8ac89beb9292332299f74c09)

Both repro's trigger ASSERTs in debug builds. Details and repros are attached to the chromium bug:
http://code.google.com/p/chromium/issues/detail?id=34575
Comment 1 Joseph Pecoraro 2010-04-06 22:47:24 PDT

*** This bug has been marked as a duplicate of bug 35791 ***