Bug 34471 - [Chromium] Implement WebFrameImpl::pageNumberForElementById
Summary: [Chromium] Implement WebFrameImpl::pageNumberForElementById
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-02 04:33 PST by Shinichiro Hamaji
Modified: 2010-02-02 20:20 PST (History)
3 users (show)

See Also:


Attachments
Patch v1 (3.02 KB, patch)
2010-02-02 04:35 PST, Shinichiro Hamaji
no flags Details | Formatted Diff | Diff
Patch v2 (3.00 KB, patch)
2010-02-02 04:48 PST, Shinichiro Hamaji
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shinichiro Hamaji 2010-02-02 04:33:58 PST
This is necessary to implement layoutTestController.pageNumberForElementById in test_shell. This API was added in http://trac.webkit.org/changeset/54205

Chromium bug: http://code.google.com/p/chromium/issues/detail?id=34219
Comment 1 Shinichiro Hamaji 2010-02-02 04:35:09 PST
Created attachment 47921 [details]
Patch v1
Comment 2 WebKit Review Bot 2010-02-02 04:40:24 PST
Attachment 47921 [details] did not pass style-queue:

Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
WebKit/chromium/src/WebFrameImpl.h:168:  page_width_in_pixels is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit/chromium/src/WebFrameImpl.h:169:  page_height_in_pixels is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit/chromium/src/WebFrameImpl.cpp:1522:  page_width_in_pixels is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit/chromium/src/WebFrameImpl.cpp:1523:  page_height_in_pixels is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit/chromium/src/WebFrameImpl.cpp:1532:  page_size is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit/chromium/public/WebFrame.h:490:  page_width_in_pixels is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit/chromium/public/WebFrame.h:491:  page_height_in_pixels is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 7


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Shinichiro Hamaji 2010-02-02 04:48:41 PST
Created attachment 47922 [details]
Patch v2
Comment 4 Shinichiro Hamaji 2010-02-02 04:49:15 PST
I've fixed the style issues. Thanks for the bot :)
Comment 5 Dimitri Glazkov (Google) 2010-02-02 08:36:14 PST
Comment on attachment 47922 [details]
Patch v2

sounds good!
Comment 6 Shinichiro Hamaji 2010-02-02 20:20:18 PST
Comment on attachment 47922 [details]
Patch v2

Clearing flags on attachment: 47922

Committed r54270: <http://trac.webkit.org/changeset/54270>
Comment 7 Shinichiro Hamaji 2010-02-02 20:20:26 PST
All reviewed patches have been landed.  Closing bug.